Closed Bug 917895 Opened 7 years ago Closed 6 years ago

[Email] Update Unread Count Banner

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

All
Other
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: epang, Assigned: pivanov)

Details

(Whiteboard: visual design, visual-tracking, jian)

Attachments

(3 files)

Attached image email-notification.png
Hi James!  Hoping you can help me out with this update.  Feel free to reassigned if I've mis-assigned :).

I think this will be a simple update. I've created a mock up for the email unread count banner.  It's not looking the greatest at the moment, can we make a couple of changes?

1. Update Banner height to 36px
2. Increase font size to to 6pt (1.4rem) with a weight of 500 (medium)

Thanks!
Hi Pavel, can you help implement this?  When ready you can flag me for feedback and review by an email peer. Thanks!
Assignee: jrburke → pivanov
Flags: needinfo?(pivanov)
Whiteboard: visual design, visual-tracking → visual design, visual-tracking, jian
Attached image After patch screenshot
Attachment #818232 - Flags: feedback?(epang)
Flags: needinfo?(pivanov)
Comment on attachment 818232 [details]
After patch screenshot

Looks good!  Thanks Pavel!
Attachment #818232 - Flags: feedback?(epang) → feedback+
Comment on attachment 818234 [details]
patch for Gaia/master

James is the best reviewer for this right now.  In terms of -moz-box-sizing, it looks like all other browsers use it unprefixed, so maybe we should include that too? (https://developer.mozilla.org/en-US/docs/CSS/box-sizing)
Attachment #818234 - Flags: review?(jrburke)
Comment on attachment 818234 [details]
patch for Gaia/master

Agree would be good to include unprefixed box-sizing below the -moz one. Even though there are other references in the email app with just the -moz version, I would to start down the cross browser path where we can, as we do changes. So with that change and a rebase/squash, r+. Tested on phone and looks good!
Attachment #818234 - Flags: review?(jrburke) → review+
Thanks guys :)

Landed on master:
https://github.com/mozilla-b2g/gaia/commit/cff8662f9f6e14065179f6dfc2b9d6c493a06c50
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Note that the landed patch removed the "-moz-box-sizing" lines, introducing a visual regression which is now tracked on bug 943103.  The requests in comment 5 and comment 6 were to add "box-sizing" directives in addition to the existing "-moz-box-sizing" lines to support other browsers, not to replace them.  (Gecko does not understand "box-sizing" and requires "-moz-box-sizing".)

I will be landing a fix momentarily on jrburke's prior review authority.
You need to log in before you can comment on or make changes to this bug.