[B2G] [Buri] [Dialer] temporary CLIR mode not work

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: CKreinbring, Assigned: hsinyi)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, firefox25 wontfix, firefox26 fixed, firefox27 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: burirun1 [comms-triage])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 806736 [details]
Log of CLIR attempt

Description:
A user that attempts to use a CLIR code before dialing a number will find that the Call button is unresponsive.

Repro Steps:
1) Update Buri to Build ID: 20130916040205
2) Launch the Phone app.
3) Enter a CLIR code (eg *#31#).
4) Tap the Call button and observe the device's reaction.

Actual:
There is no reaction.

Expected:
The code is processed and the user is shown the proper result of the code.

Environmental Variables
Occurs on Buri 1.2 Mozilla RIL
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
Test Suite Name: Dialer
UCID: owd-28087
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=9571
See attached logcat logs
Once a call has been made to another number, CLIR codes can be sent.

Updated

5 years ago
No longer blocks: 884399
blocking-b2g: --- → koi?
Keywords: regressionwindow-wanted

Updated

5 years ago
QA Contact: sparsons

Comment 1

5 years ago
This issue started to occur on the 9/09 Buri 1.2 Build ID: 20130909114657

Environmental Variables
Build ID: 20130909114657
Gecko: http://hg.mozilla.org/mozilla-central/rev/218d4334d29e
Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
Platform Version: 26.0a1
RIL Version: 01.02.00.019.043 

Last working build 9/06 Buri 1.2 Build ID: 20130906040204

Environmental Variables
Build ID: 20130906040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/ab5f29823236
Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
Platform Version: 26.0a1
RIL Version: 01.02.00.019.043
Keywords: regressionwindow-wanted
Works for me with latest m-i (148026) and MOZ RIL
(Assignee)

Comment 3

5 years ago
(In reply to Fernando Jiménez Moreno [:ferjm] (needinfo, please) from comment #2)
> Works for me with latest m-i (148026) and MOZ RIL

Works for me, too.
gecko (mozillaorg/master): e55134 (Sep. 23)

Updated

5 years ago
Blocks: 921979

Comment 4

5 years ago
Found similar issue on Buri that call can be dialed out yet number is not hidden. 
Gaia:     1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/48faa2668dd8
BuildID   20130929004004
Version   26.0a2

Log will be attached, please let me know if another bug is needed or we can track CLIR issue here.
Steps:
1. Use FET carrier account in Taiwan
2. Dial #31#09xxxxxxxx (#31# can hide MO side number)
3. MT side can still see DUT's number.

Comment 5

5 years ago
Created attachment 812493 [details]
Buri, time stamp: 15:40, 10/1.
hsinyi or fernando, do you mind looking at the logs to help the triage decide if this is a blocker or not? thanks
Whiteboard: burirun1 → burirun1 [comms-triage]
(Assignee)

Comment 7

5 years ago
Quick debug observation:
We somehow misinterpreted the meaning *31 and #31 in gecko code. We have been using *31 to hide the number rather than #31 that is wrong.

Comment 8

5 years ago
Hi HsinYi,

I wonder if this is because CDMA use *31# to hide number under APTG network. Just to let you know that *31# still needed for CDMA. But if it has nothing to do with design for CDMA, then it's fine.

Thanks.
(Assignee)

Comment 9

5 years ago
(In reply to Enpei from comment #8)
> Hi HsinYi,
> 
> I wonder if this is because CDMA use *31# to hide number under APTG network.
> Just to let you know that *31# still needed for CDMA. But if it has nothing
> to do with design for CDMA, then it's fine.
> 
> Thanks.

Enpei,

Thanks for the information. :) We have divergent ways for CDMA and GSM in this case. They should not interact.
(Assignee)

Updated

5 years ago
Summary: [B2G] [Buri] [Dialer] CLIR codes cannot be entered before a number has been called → [B2G] [Buri] [Dialer] temporary CLIR mode not work
(Assignee)

Updated

5 years ago
Assignee: nobody → htsai
(Assignee)

Comment 10

5 years ago
Created attachment 812979 [details] [diff] [review]
917922.patch
(Assignee)

Comment 11

5 years ago
Created attachment 812981 [details] [diff] [review]
917922.patch

Removing _getCLIRMode() since it repeats most checks in _isTemporaryModeCLIR().
Attachment #812979 - Attachment is obsolete: true
(Assignee)

Comment 12

5 years ago
Comment on attachment 812981 [details] [diff] [review]
917922.patch

Hi Fernanrdo,

Would you mind taking a look at this? Thank you.
Attachment #812981 - Flags: review?(ferjmoreno)
blocking-b2g: koi? → koi+
status-b2g-v1.2: --- → affected
Comment on attachment 812981 [details] [diff] [review]
917922.patch

Review of attachment 812981 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Hsin-Yi! Please, make sure that test_ril_worker_clir.js test passes before landing.
Attachment #812981 - Flags: review?(ferjmoreno) → review+
(Assignee)

Comment 14

5 years ago
Thank you, Fernando. The test passes!
https://hg.mozilla.org/integration/b2g-inbound/rev/641378038788
https://hg.mozilla.org/mozilla-central/rev/641378038788
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/ed7fc15243ac
status-b2g-v1.2: affected → fixed
status-firefox25: --- → wontfix
status-firefox26: --- → fixed
status-firefox27: --- → fixed
You need to log in before you can comment on or make changes to this bug.