self-serve per-product nightlies

RESOLVED DUPLICATE of bug 909543

Status

Release Engineering
General
RESOLVED DUPLICATE of bug 909543
5 years ago
10 months ago

People

(Reporter: aki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
We often need to respin nightlies for b2g.

On mozilla-b2g18*, QA was able to respin all nightlies from self-serve because "all nightlies" meant "all b2g nightlies".  Somewhat wasteful in resources, but the latest device build directories would be fully populated and QA didn't have to wait on releng/buildduty to trigger.

On mozilla-central or mozilla-aurora, "all nightlies" means "all b2g, fx desktop, fx mobile nightlies" and is hugely wasteful of resources.  Also, IIRC people don't want us to respin desktop nightlies off m-c/m-a because of update testing confusion (I don't know that bug off the top of my head).

I'd ideally like us to expose triggering a specific nightly (e.g. m-c hamachi nightly), but that might be a bit much here.  Maybe when our scheduling has a better story.  I'm hoping we can at least allow for triggering per-product (fx desktop, fx mobile, fx os) nightlies from self-serve, hence this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 909543
(Assignee)

Updated

10 months ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.