OfferToReceiveAudio:true constraint on createOffer causes video not to be sent

RESOLVED DUPLICATE of bug 881236

Status

()

Core
WebRTC
P3
normal
Rank:
35
RESOLVED DUPLICATE of bug 881236
5 years ago
3 years ago

People

(Reporter: jib, Assigned: abr)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC])

This is different from bug 881236 which is all about permissions on a remote call. This is about constraints and fails even on a local loop call.

STR:
1. Copy http://mozilla.github.io/webrtc-landing/pc_test.html locally
2. Find createOffer and modify:

    + var constraints = { 'mandatory': { 'OfferToReceiveAudio': true } };
    + pc1.createOffer(step1, failedOffer, constraints);
    - pc1.createOffer(step1, failedOffer);
3. Hit 'Start'

Expected: Video and audio are sent, and fake video is received.
Observed: Only audio is sent, and fake video is received.

Workaround: Remove 'OfferToReceiveAudio':true from the { }

The presence of OfferToReceiveAudio:true seems to be interpreted as "don't send video", which is wrong from how I read http://dev.w3.org/2011/webrtc/editor/webrtc.html#constraints which defines independent defaults for these values.
Whiteboard: [WebRTC]
(Assignee)

Updated

5 years ago
Assignee: nobody → adam
(Assignee)

Comment 1

5 years ago
See also Bug 881236 and Bug 929946. They may have the same or closely related causes.
Duplicate of this bug: 934911
Duplicate of this bug: 929946
I suspect this and Bug 881236 are the same underlying problem: a discrepancy between ExpectedTracks and AvailableTracks from the remote end.
Depends on: 881236

Updated

5 years ago
Blocks: 964384
Jib -- Was this fixed?
backlog: --- → webRTC+
Rank: 35
Flags: needinfo?(jib)
Priority: -- → P3
Yes (I tested it).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jib)
Resolution: --- → DUPLICATE
Duplicate of bug: 881236
You need to log in before you can comment on or make changes to this bug.