Some newly downloaded messages don't have their subject shown in the message list

RESOLVED DUPLICATE of bug 1100973

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 1100973
5 years ago
3 years ago

People

(Reporter: Martin Pecka, Unassigned)

Tracking

24 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 806894 [details]
zprava.eml

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Since update to TB 24.0 some messages don't have their subject displayed at all.

In the message list and when replying to such affected message, an empty subject is shown. In the "message header pane" the subject is shown correctly.

Not all messages are affected, though. It seems to be folder-related - messages going to Inbox or say Folder 1 are okay, whereas messages going to folders 2 and 3 have the subjects empty. Repairing the folders fixes the messages, but newly received mail in those folders gets crippled again. Moving messages to a "working" folder doesn't repair the messages, as well as moving "good" messages to the broken folders doesn't "cripple" them.

I use GMail's IMAP and have a lot of mail in the affected folders, so I don't want to try creating brand new folders and moving all the mail to them. Since repairing doesn't help, it rather seems to be a TB bug...

Whether a subject is crippled or not doesn't seem to be related to UTF8. Both ASCII and UTF8 subjects are affected.

There had to be some changes in the message list between TB23 and 24, since my Stylish script working on the "star" cell needed to be fixed. In particular, I had to change selector
treechildren::-moz-tree-image(flagged)
to 
treechildren::-moz-tree-image(flaggedCol,flagged)
in order to match only the "star" cell and not all the "flag" cells in a row.
So I think this could be a place to start investigation.
(Reporter)

Comment 1

5 years ago
Tried to receive mail with all addons disabled - the problem remains.
(Reporter)

Comment 2

5 years ago
Created attachment 806896 [details]
Screenshot of the bug

The three inconsistent places showing the subject.

Comment 3

5 years ago
could this be related to bug 917720
(Reporter)

Comment 4

5 years ago
The empty subject also appears in the new mail popup.
(Reporter)

Comment 5

5 years ago
Another update about the buggy behavior.

If the subject starts with "Re:", then that part is displayed, but everything after the "Re:" is hidden...
(Reporter)

Comment 6

5 years ago
I've been doing some research on this bug and I've found out it is probably that mime2DecodedSubject from mail/base/content/msgHdrViewOverlay.js ( http://mxr.mozilla.org/comm-central/source/mail/base/content/msgHdrViewOverlay.js#2779 ) returns the bad values. 

But I'm not very experienced in either C++ or Mozilla programming tools, so I can't find out what happens and where. 

I tried to look at the files changed between the last TB 17.0.* and TB 24, but nothing seemed to be related to email subject that could cause problems.
(Reporter)

Comment 7

5 years ago
I confirm that the same happens on Ubuntu 12.10 with TB 24.
(Reporter)

Comment 8

4 years ago
Do you have an idea on how to debug this thing? Because it still forces me to stay with TB 17 :(
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100973
You need to log in before you can comment on or make changes to this bug.