Closed Bug 918116 Opened 6 years ago Closed 6 years ago

Don't delazify scripts during Ion compilation

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: bhackett, Assigned: bhackett)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
In some circumstances, IonBuilder will delazify functions that have never been called.  This happens for inner lambdas, and for some function callees.  This behavior needs to be fixed in order to run IonBuilder off thread.  The attached patch fixes this; this includes a fix for bug 901178 as well.
Attachment #806950 - Flags: review?(jdemooij)
Thanks for taking care of that, I had an issue with bug 901178 patches which prevented me from landing the original fix, and no time to focus on it.

Your patch covers the first 2 patches of Bug 901178, but the third one is still valid.
Attachment #806950 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/72681e08a35d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Depends on: 919140
Assignee: general → bhackett1024
Depends on: 919949
Duplicate of this bug: 901178
You need to log in before you can comment on or make changes to this bug.