"Could not restore previous tabs and windows" error page on re-start with empty tab and "show windows and tabs of previous session" configured

RESOLVED DUPLICATE of bug 918276

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 918276
4 years ago
4 years ago

People

(Reporter: Joe Smith, Unassigned)

Tracking

({regression})

24 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
After updating from its previous release to the release 24.0, I see the "Could not restore previous tabs and windows" error page on re-start with an empty tab. The error is 100% reproducible on two different Firefox profiles I use.

Please note that the notions in this report are translations from the German language version, so that they might not exactly correspond to the actual English language version.


Reproduction procedure:
-----------------------
1) Make sure that Firefox is configured to start "showing windows and tabs of previous session"
2) Have several tabs open, each displaying some page
3) Open a new empty tab (by clicking on the cross next to the tabs)
4) Close all other tabs and leave only the newly opened empty tab (Note: Trying to reproduce this the first time, it might be necessary to click into the main pain (below the address bar), in order to move the cursor position away from the address bar.)
5) Close and re-open Firefox
6) Click the "restore" button
7) Close and re-open Firefox


Expected results:
-----------------
5) Firefox starts with the empty tab
6) The empty tab appears as the only tab
7) Firefox starts with the empty tab


Actual results:
---------------
5) Firefox shows the "Could not restore previous tabs and windows" error page, with the "restore" and "close" buttons.
6) OK (Although sometimes - I have the feeling that when I wait for a longer while, e.g. 5 seconds, between closing and re-opening Firefox on step 5 - the tabs closed on step 4 will be restored additionally to the empty tab. Which is not OK.)
7) Same as step 5.


The browser console thereby contains following on step 5:
[05:04:42.015] Could not read chrome manifest 'file:///C:/Programme/Mozilla%20Firefox/chrome.manifest'.
[05:04:42.238] Could not read chrome manifest 'file:///C:/Programme/Mozilla%20Firefox/browser/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
[05:04:42.245] While creating services from category 'profile-after-change', could not create service for entry 'Disk Space Watcher Service', contract ID '@mozilla.org/toolkit/disk-space-watcher;1'
--
[05:04:55.747] 1379559895747	Services.HealthReport.HealthReporter	WARN	Saved state file does not exist.

[05:04:55.747] 1379559895747	Services.HealthReport.HealthReporter	WARN	No prefs data found.

--
[05:07:36.483] WARN addons.updates: HTTP Request failed for an unknown reason @ resource://gre/modules/AddonUpdateChecker.jsm:521



===============================================
Configuration info (from the Help menu, German version):

Allgemeine Informationen
------------------------

Name: Firefox
Version: 24.0
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

Erweiterungen
-------------

Name: Microsoft .NET Framework Assistant
Version: 0.0.0
Aktiviert: false
ID: {20a82645-c095-46ed-80e3-08825760534b}

Wichtige modifizierte Einstellungen
-----------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 1048576
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size_cached_value: 819200
browser.places.smartBookmarksVersion: 4
browser.search.update: false
browser.startup.homepage_override.buildID: 20130730113002
browser.startup.homepage_override.mstone: ignore
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 24.0
gfx.blacklist.suggested-driver-version: 6.14.10.5260
media.navigator.enabled: false
network.cookie.lifetimePolicy: 2
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1379558292
places.history.expiration.transient_current_max_pages: 26585
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.npdrmv: 0
plugin.state.npdsplay: 0
plugin.state.npwmsdrm: 0
plugin.state.npwpf: 0
plugins.hide_infobar_for_missing_plugin: true
plugins.notifyMissingFlash: false
privacy.clearOnShutdown.downloads: false
privacy.clearOnShutdown.history: false
privacy.clearOnShutdown.offlineApps: true
privacy.clearOnShutdown.passwords: true
privacy.cpd.cookies: false
privacy.cpd.downloads: false
privacy.cpd.history: false
privacy.cpd.offlineApps: true
privacy.cpd.sessions: false
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.sanitizeOnShutdown: true
security.warn_viewing_mixed: false
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1376014062

Grafik
------

Direct2D aktiviert: Wurde auf Grund Ihrer Grafiktreiberversion blockiert. Versuchen Sie, Ihren Grafiktreiber auf mindestens Version 6.14.10.5260 zu aktualisieren.
DirectWrite aktiviert: false (0.0.0.0)
Geräte-ID: 0xa011
GPU #2 aktiv: false
GPU-beschleunigte Fenster: 0/1 Basic
Karten-Beschreibung: Intel(R) Graphics Media Accelerator 3150
Karten-RAM: Unknown
Karten-Treiber: igxprd32
Treiber-Datum: 9-24-2009
Treiber-Version: 6.14.10.5134
Vendor-ID: 0x8086
WebGL-Renderer: Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator 3150 Direct3D9 vs_0_0 ps_2_0)
windowLayerManagerRemote: false
AzureCanvasBackend: skia
AzureContentBackend: none
AzureFallbackCanvasBackend: cairo

JavaScript
----------

Inkrementelle GC: true

Barrierefreiheit
----------------

Aktiviert: false
Barrierefreiheit verhindern: 0

Bibliotheken-Versionen
----------------------

NSPR
Minimal vorausgesetzte Version: 4.10
Verwendete Version: 4.10

NSS
Minimal vorausgesetzte Version: 3.15.1 Basic ECC
Verwendete Version: 3.15.1 Basic ECC

NSSSMIME
Minimal vorausgesetzte Version: 3.15.1 Basic ECC
Verwendete Version: 3.15.1 Basic ECC

NSSSSL
Minimal vorausgesetzte Version: 3.15.1 Basic ECC
Verwendete Version: 3.15.1 Basic ECC

NSSUTIL
Minimal vorausgesetzte Version: 3.15.1
Verwendete Version: 3.15.1
After updating from its previous release to the release 24.0, I see the "Could not restore previous tabs and windows" error page on re-start with an empty tab. The error is 100% reproducible on two different Firefox profiles I use.

Please note that the notions in this report are translations from the German language version, so that they might not exactly correspond to the actual English language version.


Reproduction procedure:
-----------------------
1) Make sure that Firefox is configured to start "showing windows and tabs of previous session"
2) Have several tabs open, each displaying some page
3) Open a new empty tab (by clicking on the cross next to the tabs)
4) Close all other tabs and leave only the newly opened empty tab (Note: Trying to reproduce this the first time, it might be necessary to click into the main pain (below the address bar), in order to move the cursor position away from the address bar.)
5) Close and re-open Firefox
6) Click the "restore" button
7) Close and re-open Firefox


Expected results:
-----------------
5) Firefox starts with the empty tab
6) The empty tab appears as the only tab
7) Firefox starts with the empty tab


Actual results:
---------------
5) Firefox shows the "Could not restore previous tabs and windows" error page, with the "restore" and "close" buttons.
6) OK (Although sometimes - I have the feeling that when I wait for a longer while, e.g. 5 seconds, between closing and re-opening Firefox on step 5 - the tabs closed on step 4 will be restored additionally to the empty tab. Which is not OK.)
7) Same as step 5.


The browser console thereby contains the following on step 5:
[05:04:42.015] Could not read chrome manifest 'file:///C:/Programme/Mozilla%20Firefox/chrome.manifest'.
[05:04:42.238] Could not read chrome manifest 'file:///C:/Programme/Mozilla%20Firefox/browser/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
[05:04:42.245] While creating services from category 'profile-after-change', could not create service for entry 'Disk Space Watcher Service', contract ID '@mozilla.org/toolkit/disk-space-watcher;1'
--
[05:04:55.747] 1379559895747	Services.HealthReport.HealthReporter	WARN	Saved state file does not exist.

[05:04:55.747] 1379559895747	Services.HealthReport.HealthReporter	WARN	No prefs data found.

--
[05:07:36.483] WARN addons.updates: HTTP Request failed for an unknown reason @ resource://gre/modules/AddonUpdateChecker.jsm:521



===============================================
Configuration info (from the Help menu, German version):

Allgemeine Informationen
------------------------

Name: Firefox
Version: 24.0
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

Erweiterungen
-------------

Name: Microsoft .NET Framework Assistant
Version: 0.0.0
Aktiviert: false
ID: {20a82645-c095-46ed-80e3-08825760534b}

Wichtige modifizierte Einstellungen
-----------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 1048576
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size_cached_value: 819200
browser.places.smartBookmarksVersion: 4
browser.search.update: false
browser.startup.homepage_override.buildID: 20130730113002
browser.startup.homepage_override.mstone: ignore
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 24.0
gfx.blacklist.suggested-driver-version: 6.14.10.5260
media.navigator.enabled: false
network.cookie.lifetimePolicy: 2
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1379558292
places.history.expiration.transient_current_max_pages: 26585
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.npdrmv: 0
plugin.state.npdsplay: 0
plugin.state.npwmsdrm: 0
plugin.state.npwpf: 0
plugins.hide_infobar_for_missing_plugin: true
plugins.notifyMissingFlash: false
privacy.clearOnShutdown.downloads: false
privacy.clearOnShutdown.history: false
privacy.clearOnShutdown.offlineApps: true
privacy.clearOnShutdown.passwords: true
privacy.cpd.cookies: false
privacy.cpd.downloads: false
privacy.cpd.history: false
privacy.cpd.offlineApps: true
privacy.cpd.sessions: false
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.sanitizeOnShutdown: true
security.warn_viewing_mixed: false
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1376014062

Grafik
------

Direct2D aktiviert: Wurde auf Grund Ihrer Grafiktreiberversion blockiert. Versuchen Sie, Ihren Grafiktreiber auf mindestens Version 6.14.10.5260 zu aktualisieren.
DirectWrite aktiviert: false (0.0.0.0)
Geräte-ID: 0xa011
GPU #2 aktiv: false
GPU-beschleunigte Fenster: 0/1 Basic
Karten-Beschreibung: Intel(R) Graphics Media Accelerator 3150
Karten-RAM: Unknown
Karten-Treiber: igxprd32
Treiber-Datum: 9-24-2009
Treiber-Version: 6.14.10.5134
Vendor-ID: 0x8086
WebGL-Renderer: Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator 3150 Direct3D9 vs_0_0 ps_2_0)
windowLayerManagerRemote: false
AzureCanvasBackend: skia
AzureContentBackend: none
AzureFallbackCanvasBackend: cairo

JavaScript
----------

Inkrementelle GC: true

Barrierefreiheit
----------------

Aktiviert: false
Barrierefreiheit verhindern: 0

Bibliotheken-Versionen
----------------------

NSPR
Minimal vorausgesetzte Version: 4.10
Verwendete Version: 4.10

NSS
Minimal vorausgesetzte Version: 3.15.1 Basic ECC
Verwendete Version: 3.15.1 Basic ECC

NSSSMIME
Minimal vorausgesetzte Version: 3.15.1 Basic ECC
Verwendete Version: 3.15.1 Basic ECC

NSSSSL
Minimal vorausgesetzte Version: 3.15.1 Basic ECC
Verwendete Version: 3.15.1 Basic ECC

NSSUTIL
Minimal vorausgesetzte Version: 3.15.1
Verwendete Version: 3.15.1
(Reporter)

Updated

4 years ago
Keywords: regression
(Reporter)

Comment 1

4 years ago
Sorry, I apparently pasted the bug description text twice into the description field.

Updated

4 years ago
Component: Untriaged → Session Restore
(Reporter)

Comment 2

4 years ago
I'm marking this bug as duplicate even though it's one day older than the other one, because the other one has more followers and some analysis already performed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918276
You need to log in before you can comment on or make changes to this bug.