Closed Bug 918276 Opened 8 years ago Closed 8 years ago

Prompted by about:sessionrestore when closing all tabs and restarting

Categories

(Firefox :: Session Restore, defect)

24 Branch
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Tracking Status
firefox24 - ---
firefox25 + wontfix
firefox26 --- verified
firefox27 + verified

People

(Reporter: aloisio, Assigned: ttaubert)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911155223

Steps to reproduce:

After upgrading from version 23 to version 24 (linuxmint x86_64) this started happening:

I closed all tabs and quit the browser, then launched it anew.



Actual results:

Firefox asked to restore the tabs I had closed in the last session.



Expected results:

I expected to see a blank tab.
Component: Untriaged → Session Restore
EDIT: I forgot to mention that "Show My Windows and Tabs from last time" is set.
EDIT2: The problem occurs if the browser is closed from the window button, but not if quit from the file menu.
EDIT3: I could still reproduce it in a clean profile with the official ff24 x86_64 build from mozilla and with every plugin and extension disabled. The only things I changed from default were:

browser.tabs.closeWindowWithLastTab set to false
"Show My Windows and Tabs from last time" as startup behaviour
and hid the tab thumbnails.
EDIT4: Setting about:config?filter=browser.sessionstore.resume_from_crash to false in the above-mentioned test profile, sessionrestore didn't prompt me again but the previously closed tabs are being restored automatically
(for some unclear reason the initial behaviour was different, namely opening the homepage instead of restoring; haven't been able to reproduce that).
Yes, this appears to be a regression in Firefox 24. I can reliably reproduce it in 24 and Nightly using the STR below, but not in 23 (tested using Linux 64-bit builds).

Steps to Reproduce:

1. Start Firefox using a new profile
2. Load about:config and set
     browser.startup.page = 3
     browser.tabs.closeWindowWithLastTab = false
3. Close all open tabs (the last tab closed should be replaced by a new tab)
4. Wait ~30 seconds
5. Close Firefox using the Close button on the window frame
6. Restart Firefox (the new tab page should appear)
7. Load https://bugzilla.mozilla.org into the existing tab
8. Close the tab
9. Wait ~30 seconds
10. Close Firefox using the Close button on the window frame
11. Restart Firefox

Expected result:

The new tab page appears.

Actual result:

The "restore session" window appears.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The regression range is

Last good nightly: 2013-06-20
First bad nightly: 2013-06-21

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8ea92aeab783&tochange=7ba8c86f1a56
STR in comment #5 look like STR in bug 886926 which is a dupe of bug 495123.
Am I wrong somewhere else? (because you found a regression range)
Yes, it looks similar to bug 886926. But I don't think bug 886926 is a dupe of bug 495123.

Bug 495123 is about previously closed windows being reopened, and has been around for several years (I've experienced it myself). This one is a new bug, not present in FF23, that causes the session restore window to be incorrectly shown.

If bug 886926 can be reproduced in the 2013-06-21 nightly but not in the 2013-06-20 nightly, then I think it's the same bug as this.
Further bisecting shows that it's caused by this changeset:

changeset:   135904:80cd0ed2e33c
user:        Sid <sidrabbit@xxxxxxxx>
date:        Thu Jun 20 20:06:14 2013 +0200
summary:     Bug 884585 - Exclude about:newtab from Recently Closed Tabs list; r=ttaubert
Blocks: 884585
Duplicate of this bug: 886926
It's bad I missed this regression because I reported it only a few days after bug 884585 landed in Nightly. Now the bug is in the release version. :/
I've done some more testing and can reproduce it reliably even with default preferences. (I'll confirm later that it's the same regression, but I'm pretty sure it is).

Revised STR:

1. Start Firefox using a new profile
2. Open a new tab
3. Close all tabs apart from the new tab you just opened
4. Wait ~30 seconds
5. Close Firefox using the Close button on the window frame
6. Restart Firefox
7. Wait ~30 seconds
8. Close Firefox using the Close button on the window frame
9. Restart Firefox

Expected result:

The new tab page appears.

Actual result:

The "restore session" page appears.
Duplicate of this bug: 918689
I've noticed something else. In Step 6 of the revised STR, Firefox opens with the new tab page loaded. But the startup settings weren't changed from the default, so it should have shown the default home page.

(Similarly, the "Expected result" should be that the default home page is loaded, not the new tab page as I stated.)
This is not worth tracking for FF24, but we will track for FF25 and up. ttaubert, can you help with a backout or forward fix?
Assignee: nobody → ttaubert
Alex, I'd like you to reconsider tracking this for FF24. This affects me every time I start Firefox, and it's very annoying.
Duplicate of this bug: 918195
Same on WinXP 32 bit. See bug 918195 for configuration details.

Reproduction procedure:
-----------------------
1) Make sure that Firefox is configured to start "showing windows and tabs of previous session"
2) Have several tabs open, each displaying some page
3) Open a new empty tab (by clicking on the cross next to the tabs)
4) Close all other tabs and leave only the newly opened empty tab (Note: Trying to reproduce this the first time, it might be necessary to click into the main pain (below the address bar), in order to move the cursor position away from the address bar.)
5) Close and re-open Firefox
6) Click the "restore" button
7) Close and re-open Firefox


Expected results:
-----------------
5) Firefox starts with the empty tab
6) The empty tab appears as the only tab
7) Firefox starts with the empty tab


Actual results:
---------------
5) Firefox shows the "Could not restore previous tabs and windows" error page, with the "restore" and "close" buttons.
6) OK (Although sometimes - I have the feeling that when I wait for a longer while, e.g. 5 seconds, between closing and re-opening Firefox on step 5 - the tabs closed on step 4 will be restored additionally to the empty tab. Which is not OK.)
7) Same as step 5.
What makes this bug particularly painful is that users trying to diagnose it will be fooled into thinking something is causing their Firefox to crash (but about:crashes will be empty). Similarly, a lot of "Firefox keeps crashing" reports will actually be this bug.

The STR aren't all that hard to hit either, though I'm guessing we missed it in Nightly/Aurora/Beta because more advanced users are likely to have more tabs and simply not close the browser at all, and then combined with the above issue...sigh :(
Severity: normal → critical
Btw, this happens with a clean profile as well. Setting "Show my windows and tabs from last time" is NOT required.
> The STR aren't all that hard to hit either, though I'm guessing we missed it
> in Nightly/Aurora/Beta because more advanced users are likely to have more
> tabs and simply not close the browser at all, and then combined with the
> above issue...sigh :(

I reported 2 days after the regression landed in Nightly (see bug 886926) but the bug has been closed based on a wrong assertion. :/
Duplicate of this bug: 889796
Yes, it seems to be fixed. I tested with the linux x64 build and was unable to reproduce the bug. :)
Well I just upgraded to firefox 24.0 today,  and the behavior still isn't fixed.
mjh563, thanks for checking!
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
Can't repro it too.
>Well I just upgraded to firefox 24.0 today,  and the behavior still isn't fixed.

The fix went into the current development version (Firefox 27 aka Nightly), not the current release.
Marking as fixed by bug 853779.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 928694
Disappointed. =(

This affects me 40-50 times a day, at least. I was assuming a fix for 25, even if I think you should solve it for 24. To have to wait for 26 makes me sad, I'm really starting to loose faith here.
(In reply to Anders Öhrt from comment #31)
> Disappointed. =(
> 
> This affects me 40-50 times a day, at least. I was assuming a fix for 25,
> even if I think you should solve it for 24. To have to wait for 26 makes me
> sad, I'm really starting to loose faith here.

The workaround is simple, stop closing Firefox with only about:blank open. Keep some tabs open when you're closing Firefox.
Anyway, are you sure you need to start and close Firefox 40 times per day?
My current workaround is to simple Ctrl-W to close the session restore window when it shows, but each time my opinion of FF gets a little worse. I'm a long time user, so I'm saddened by this. I usually recommend FF to everyone, so I want to keep loving it, but it's getting harder unfortunately.

I close Firefox whenever I'm not using it, I'm OCD like that. To start it is just a hot-key away, and that's been working fine since 3.x up until now...
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed in latest Nightly 27.0a1 (buildID: 20131022030202).
Duplicate of this bug: 931678
This should be fixed-26 by bug 853779, right?
Flags: needinfo?(ttaubert)
Yes, that is indeed fixed for Firefox 26+. Sorry, I forgot to follow up on this one.
Flags: needinfo?(ttaubert)
Keywords: verifyme
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed Firefox 26 beta 2 (buildID: 20131104182142) and latest Aurora 27.0a2 (buildID: 20131107004005)
Status: RESOLVED → VERIFIED
Keywords: verifyme
firefox 26
26.0+build2-0ubuntu0.13.10.2

ubuntu 13.10 x64
Linux jumper-home 3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:04:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I have this issue from time to time
Extreamly annoying bug
Every time I start firefox (which was closed with one empty tab) random popup window from history opens.
That's a different bug, please file it.
>Extreamly annoying bug
>Every time I start firefox (which was closed with one empty tab) random popup window from history opens.

For the record this is bug 495123.
You need to log in before you can comment on or make changes to this bug.