[dev][stage]Nonexistent WebappRuntime version displayed on homepage

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: AlinT, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 807171 [details]
Nonexistent version displayed on homepage

This issue is reproducible both on dev and stage.

STR:
1.Go to https://crash-stats.allizom.org
2. Select "WebappRuntime" from the product list
3. Wait for page to load

Expected results:
The product versions displayed on the page, should correspond to actual product versions.

Actual results:
"WebappRuntime 24.0b8" in not a version of WebappRuntime, because it's last version is 24.0b6. Also clicking it returns "Page not found"

Screenshots of the issue are attached.
(Reporter)

Comment 1

5 years ago
Created attachment 807172 [details]
PageNotFound

Comment 2

5 years ago
On prod, 24.0b8 exists for this product for sure, so maybe this is just data inconsistency due to what was copied from prod to stage?
(Reporter)

Comment 3

5 years ago
I don't think 24.0b8 exists on prod: https://crash-stats.mozilla.com/topcrasher/products/WebappRuntime/versions/24.0b8?days=7
Or it was"lost"

Comment 4

5 years ago
Hmm, it should exist, as WebappRuntime is 1:1 parallel with Firefox, but maybe it ran into the sunset_date issues we had with Firefox due to the rapid beta stuff.

Comment 5

5 years ago
BTW, same seems to be true for MetroFirefox.
(Reporter)

Updated

5 years ago
Summary: [dev][stage]Nonexistent product version displayed on homepage → [dev][stage]Nonexistent WebappRuntime version displayed on homepage
Can we close this now that the WebappRuntime product has been retired (bug 1238129)?
Thanks :marco -- bumping to resolved fixed per bug 1238129.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.