Closed Bug 91832 Opened 18 years ago Closed 7 years ago

Implement bookmark queueing

Categories

(SeaMonkey :: Bookmarks & History, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: xyzzy, Unassigned)

References

Details

(Keywords: helpwanted, Whiteboard: [2012 Fall Equinox])

After reading bug 18213 (Offline to-do list) and bug 63664 (Temporary 
Bookmarks), I became convinced that this enhancement would provide a 
broader solution...

What I would like to see is some sort of bookmark/site queue available both 
offline and online.  When offline, it would support the functionality described 
in bug 18213, but when online it could be used as an alternative to the open new 
window menu item.

My browsing behavior is such that I often end up doing breadth-first searches on 
search engine hits, and the system quickly gets bogged down with a bunch of open 
windows that I am only spawning because I don't want to bookmark them.  This 
would give me a centralized location to grab links that look interesting, but I 
have yet to explore, without the performance issues of creating a new window for 
each or the persistence of bookmarks.

I don't know how this would fit into the UI.  I suppose the sidebar is my most 
intuitive guess.

Would we would want to support the caching implications that are suggested in 
bug 63664?
After putting in some more thought, I realized that my conception of a "queue" 
may be overly broad for my audience.  My intent certainly includes the standard 
meaning, but might also be extended to some kind of list (ordered or not), or 
even a FIFO, as appropriate.

Some more digging, and I found these bugs, which seem to offer other solutions, 
or further illustrate the necessity of some common meta-solution.

Bug 9274  - Open multiple new windows at once.
Bug 39245 - Slide Show
Bug 43641 - Set forward browsing preferences
Bug 59126 - Multiple tabbed windows
Bug 56690 - Open link in a new window behind current window

I still think that there is a need for a solution which conserves memory by not 
opening windows left and right, as some of these propose.  The slide show seems 
most intriguing, but again, caching behavior comes into play...  Depending on 
implementation, a queue might suffer the same navigation issues as raised by 
that bug, however.  A sidebar interface, with up/down navigational arrows may 
help.
Additional thoughts:

1) A range selection might be able to dump all enclosed links to the queue.
2) The queue could be persistent across sessions.
3) A modifier key + click could be used to queue items.

More similar bugs:

Bug 80588 Embedded multiple windows
Bug 88654 Group Sites for Simultaneous Open (want Simultaneous Queueing)
Bug 89922 Command Key Opens Sidebar Bookmarks in new Window

This is getting broad enough to spin off additional bugs, but still waiting for 
some feedback and a go/nogo.
sure make sure you make the new bugs blocking this one. Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
sounds like an add-on
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5
See also my <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=18213#c27"> 
comment</a> in bug 18213, for a few suggestions.
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
Summary: [RFE] Implement bookmark queueing → Implement bookmark queueing
I just had about the same idea, motivated by the fact that when the browser (or
the system) crashes, the information of the list of URLs of open windows is
lost. (then, when I heard that the history could be visited by ctrl-h, the
history was lost, too, as reported in 102519).
Other related problems are 18341,111141,56690,157060,103392,61178,112531,87969.

So, more suggestions:
- This list contains at least all URLs of open browser windows.
- It is saved to disk at every modification (so, this protects from crash, and
is also useful when one says: uh, I have no more time now, I must shut down and
come back browsing all this later).
- There would be more ways of visiting a link, for example accessible by the
right-click menu (instead of just the present functions of left-click and
middle-click to the link): Add link to the list/open in new window/go to link
letting present page in list/go to link removing present page from list.
In the preferences, one could choose the functions of left and middle click
among these.
- There would be many ways of closing a window by different ctrl keys instead of
the present only ctrl-w key: Close keeping in the list/close removing from the
list/go to next URL from the list, keeping or not the present page in the list.
- One could see the list displayed, for example like a browsed bookmarks.html
page with descriptions, and delete or move each link to bookmarks.

So, this may look like too many features that require many ctrl keys or mouse
buttons, but we could think of simplifying this by things like "mark the present
page as read" to remove it from the list at the next operation.
Product: Browser → Seamonkey
Assignee: bugs → nobody
QA Contact: claudius → bookmarks
Duplicate of this bug: 18213
Duplicate of this bug: 63664
Sounds more like a good idea for add-on, don't think that majority of users would benefit if this would be implemented. Anyway, still valid RFE
Whiteboard: [2012 Fall Equinox]
WONTFIX plus extension fodder. I've seen several Firefox extensions that do this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.