Don't show the user message about Publishers to admins accessing /curation

RESOLVED FIXED

Status

Marketplace
Admin Tools
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
steps to reproduce:
1. As an admin, load https://marketplace-dev.allizom.org/curation/
2. Notice the user message "In order to create or modify collections, you must be logged in as a Marketplace Publisher to effectively use this tool."


observed behavior:
That user message is not true for admins since they have full access. Let's not show that message to people with access.

Comment 1

4 years ago
This happens because you haven't logged in since the publisher permission was added. We only update your local permission list when you log in, so logging out and logging in should fix this. You can log in/out from any commonplace project (fireplace, rocketfuel, new stats, commbadge, etc.).

If you're still having this issue after logging out and back in, reopen please.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(In reply to krupa raj[:krupa] from comment #0)
> observed behavior:
> That user message is not true for admins since they have full access. Let's
> not show that message to people with access.

Apparently, this isn't true. Adora is an admin and she was unable to use the tool until I asked Jason to explicitly grant her Apps:Publisher privileges.

Sounds like we have a bug.

Comment 3

4 years ago
(In reply to Christopher Van Wiemeersch [:cvan] from comment #2)
> (In reply to krupa raj[:krupa] from comment #0)
> > observed behavior:
> > That user message is not true for admins since they have full access. Let's
> > not show that message to people with access.
> 
> Apparently, this isn't true. Adora is an admin and she was unable to use the
> tool until I asked Jason to explicitly grant her Apps:Publisher privileges.
> 
> Sounds like we have a bug.

Did Adora log out and back in?
(In reply to Matt Basta [:basta] from comment #3)
> (In reply to Christopher Van Wiemeersch [:cvan] from comment #2)
> > (In reply to krupa raj[:krupa] from comment #0)
> > > observed behavior:
> > > That user message is not true for admins since they have full access. Let's
> > > not show that message to people with access.
> > 
> > Apparently, this isn't true. Adora is an admin and she was unable to use the
> > tool until I asked Jason to explicitly grant her Apps:Publisher privileges.
> > 
> > Sounds like we have a bug.
> 
> Did Adora log out and back in?

Yep, I told her to. And she claimed she did.
(Reporter)

Comment 5

4 years ago
(In reply to Matt Basta [:basta] from comment #1)
> This happens because you haven't logged in since the publisher permission
> was added. We only update your local permission list when you log in, so
> logging out and logging in should fix this. You can log in/out from any
> commonplace project (fireplace, rocketfuel, new stats, commbadge, etc.).
> 
> If you're still having this issue after logging out and back in, reopen
> please.

Logging out and logging back in didn't help.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

4 years ago
Oh wait, nevermind. Chuck changed the name of the permission coming back from the API and didn't tell anyone.

CHUCK!

https://github.com/mozilla/rocketfuel/commit/724fe0d4ca9a8d75324f30c076f9172747a60b26
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
I totally did tell you: https://github.com/mozilla/zamboni/pull/1098#discussion_r6252469

Comment 8

4 years ago
I love how you made an important note about an important change in the middle of a many-dozen comment review for which I get emails about each comment, not just ones where I'm mentioned
thanks everyone! :)
You need to log in before you can comment on or make changes to this bug.