Fix release mozconfigs for android before 25.0b2

RESOLVED FIXED in Firefox 25

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: hwine, Assigned: blassey)

Tracking

unspecified
Firefox 25
Points:
---

Firefox Tracking Flags

(firefox25+ fixed, firefox26 fixed, firefox27 fixed, firefox28 fixed, b2g-v1.2 fixed)

Details

Attachments

(3 attachments)

For 25.0b1 we temporarily white listed a large number of configuration changes (see bug 917369). Those were backed out as soon as 25.0b1 shipped (see bug 918435).

This bug is to get the correct values set in the release configuration, so 25.0b2 will start smoothly.
I have no idea what you're talking about
Assignee: blassey.bugs → nobody
These are changes that were made to the nightly mozconfigs, but not to the release mozconfigs. For example:
  http://hg.mozilla.org/releases/mozilla-beta/log/a9d943ed17dd/mobile/android/config/mozconfigs/android/nightly
shows various changes that you incorporated into the nightly mozconfigs back in July, but
  http://hg.mozilla.org/releases/mozilla-beta/log/a9d943ed17dd/mobile/android/config/mozconfigs/android/release
shows the release mozconfigs haven't been changed since May.

For gecko 26 on, such a difference will be caught during nightly builds. For 25 and before, they are only detected on uplift to beta. To allow fennec 25.0b1 to be shipped on time, releng temporarily whitelisted all those changes. We will/have removed those temporary changes when 25.0b1 ships (bug 918435).
Flags: needinfo?(blassey.bugs)
Summary: Fix release configation for fennec before 25.0b2 → Fix release mozconfigs for android before 25.0b2
bug 918435 resolved, so 25.0b2 will definitely fail release sanity until this is addressed. 

Heading out on PTO, so re-assigning to :blassey to ensure comment 2 answers all open questions before I leave.
Assignee: nobody → blassey.bugs
This will cause issues for 25.0b2, which should go to build today.
Attachment #808700 - Flags: review?(bhearsum)
Flags: needinfo?(blassey.bugs)
Component: Build Config → General
Product: Firefox → Firefox for Android
Version: 11 Branch → unspecified
Comment on attachment 808700 [details] [diff] [review]
release_use_common.patch

Review of attachment 808700 [details] [diff] [review]:
-----------------------------------------------------------------

I'm deferring this to Hal or Aki because they have more context on this than me.
Attachment #808700 - Flags: review?(hwine)
Attachment #808700 - Flags: review?(bhearsum)
Attachment #808700 - Flags: review?(aki)
Comment on attachment 808700 [details] [diff] [review]
release_use_common.patch

Overall I think this is a win.

I will note that some lines are showing up in a diff that will probably cause issues:

* the |ac_add_options --with-branding=mobile/android/branding/beta| line is in different locations in the {nightly,release} pairs, so it shows up and will cause issues.  I don't like the fact that we're line-order-dependent, but it's hard to work around this, since we also do shell scripting in mozconfigs.

* we probably need the |export JAVA_HOME=/tools/jdk6| line back in the armv6 release mozconfig since it now shows up in the diff.

I want to figure out how to run the mozconfig diff locally, so I can give a real signoff.
(In reply to Aki Sasaki [:aki] from comment #7)
> I want to figure out how to run the mozconfig diff locally, so I can give a
> real signoff.

Did so.  Can't wait til we have this running per-checkin so we don't have to go through this again.

I think we have to fix the ERRORs below; I'll take a stab at it:

2013-09-23 14:28:28,198 : INFO : Comparing fennec mozconfigs to nightly mozconfigs...
2013-09-23 14:28:28,214 : WARNING : ac_add_options --target=arm-linux-androideabi not in android-armv6 ['ac_add_options --enable-update-channel=nightly', 'mk_add_options CLIENT_PY_ARGS="--hg-options=\'--verbose --time\' --hgtool=../tools/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --skip-venkman --tinderbox-print"', 'ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}', 'ac_add_options --enable-warnings-as-errors', 'ac_add_options --with-ccache=/usr/bin/ccache']!
2013-09-23 14:28:28,214 : ERROR : found in mobile/android/config/mozconfigs/android-armv6/nightly but not in mobile/android/config/mozconfigs/android-armv6/release: ac_add_options --target=arm-linux-androideabi
2013-09-23 14:28:28,214 : WARNING : export MOZ_PKG_SPECIAL=armv6 not in android-armv6 ['ac_add_options --enable-update-channel=nightly', 'mk_add_options CLIENT_PY_ARGS="--hg-options=\'--verbose --time\' --hgtool=../tools/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --skip-venkman --tinderbox-print"', 'ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}', 'ac_add_options --enable-warnings-as-errors', 'ac_add_options --with-ccache=/usr/bin/ccache']!
2013-09-23 14:28:28,214 : ERROR : found in mobile/android/config/mozconfigs/android-armv6/nightly but not in mobile/android/config/mozconfigs/android-armv6/release: export MOZ_PKG_SPECIAL=armv6
2013-09-23 14:28:28,214 : WARNING : ac_add_options --with-branding=mobile/android/branding/beta not in android-armv6 ['ac_add_options --enable-update-channel=nightly', 'mk_add_options CLIENT_PY_ARGS="--hg-options=\'--verbose --time\' --hgtool=../tools/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --skip-venkman --tinderbox-print"', 'ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}', 'ac_add_options --enable-warnings-as-errors', 'ac_add_options --with-ccache=/usr/bin/ccache']!
2013-09-23 14:28:28,214 : ERROR : found in mobile/android/config/mozconfigs/android-armv6/nightly but not in mobile/android/config/mozconfigs/android-armv6/release: ac_add_options --with-branding=mobile/android/branding/beta
2013-09-23 14:28:28,214 : WARNING : export JAVA_HOME=/tools/jdk6 not in android-armv6 ['ac_add_options --enable-update-channel=nightly', 'mk_add_options CLIENT_PY_ARGS="--hg-options=\'--verbose --time\' --hgtool=../tools/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --skip-venkman --tinderbox-print"', 'ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}', 'ac_add_options --enable-warnings-as-errors', 'ac_add_options --with-ccache=/usr/bin/ccache']!
2013-09-23 14:28:28,214 : ERROR : found in mobile/android/config/mozconfigs/android-armv6/nightly but not in mobile/android/config/mozconfigs/android-armv6/release: export JAVA_HOME=/tools/jdk6
2013-09-23 14:28:28,214 : ERROR : found in mobile/android/config/mozconfigs/android-armv6/release but not in mobile/android/config/mozconfigs/android-armv6/nightly: export MOZ_PKG_SPECIAL=armv6
2013-09-23 14:28:28,214 : ERROR : found in mobile/android/config/mozconfigs/android-armv6/release but not in mobile/android/config/mozconfigs/android-armv6/nightly: ac_add_options --with-branding=mobile/android/branding/beta
2013-09-23 14:28:28,216 : WARNING : ac_add_options --enable-profiling not in android-x86 ['ac_add_options --enable-update-channel=nightly', 'mk_add_options CLIENT_PY_ARGS="--hg-options=\'--verbose --time\' --hgtool=../tools/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --skip-venkman --tinderbox-print"', 'ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}', 'ac_add_options --enable-warnings-as-errors', 'ac_add_options --with-ccache=/usr/bin/ccache']!
2013-09-23 14:28:28,216 : ERROR : found in mobile/android/config/mozconfigs/android-x86/nightly but not in mobile/android/config/mozconfigs/android-x86/release: ac_add_options --enable-profiling
2013-09-23 14:28:28,217 : WARNING : ac_add_options --disable-elf-hack # --enable-elf-hack conflicts with --enable-profiling not in android-x86 ['ac_add_options --enable-update-channel=nightly', 'mk_add_options CLIENT_PY_ARGS="--hg-options=\'--verbose --time\' --hgtool=../tools/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --skip-venkman --tinderbox-print"', 'ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}', 'ac_add_options --enable-warnings-as-errors', 'ac_add_options --with-ccache=/usr/bin/ccache']!
2013-09-23 14:28:28,217 : ERROR : found in mobile/android/config/mozconfigs/android-x86/nightly but not in mobile/android/config/mozconfigs/android-x86/release: ac_add_options --disable-elf-hack # --enable-elf-hack conflicts with --enable-profiling
2013-09-23 14:28:28,217 : WARNING : STRIP_FLAGS="--strip-debug" not in android-x86 ['ac_add_options --enable-update-channel=nightly', 'mk_add_options CLIENT_PY_ARGS="--hg-options=\'--verbose --time\' --hgtool=../tools/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --skip-venkman --tinderbox-print"', 'ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}', 'ac_add_options --enable-warnings-as-errors', 'ac_add_options --with-ccache=/usr/bin/ccache']!
2013-09-23 14:28:28,217 : ERROR : found in mobile/android/config/mozconfigs/android-x86/nightly but not in mobile/android/config/mozconfigs/android-x86/release: STRIP_FLAGS="--strip-debug"
2013-09-23 14:28:28,217 : ERROR : Error verifying mozconfigs
Takes attachment 808700 [details] [diff] [review], then gets it passing the mozconfig check (with a tools patch, incoming).
Attachment #808815 - Flags: review?(blassey.bugs)
This gets the mozconfig check to ignore these three lines for x86 (exists in nightly, but not release):

+    'ac_add_options --enable-profiling',
+    'ac_add_options --disable-elf-hack # --enable-elf-hack conflicts with --enable-profiling',
+    'STRIP_FLAGS="--strip-debug"',

We already have these three lines in the whitelist for android (armv7).
Attachment #808817 - Flags: review?(blassey.bugs)
Comment on attachment 808815 [details] [diff] [review]
mozconfig.diff

Just in case Brad's busy or afk.
Attachment #808815 - Flags: review?(rail)
Attachment #808817 - Flags: review?(rail)
Attachment #808817 - Flags: review?(rail) → review+
Comment on attachment 808815 [details] [diff] [review]
mozconfig.diff

lgtm
I haven't verified it with release sanity though.
Attachment #808815 - Flags: review?(rail) → review+
Attachment #808815 - Flags: approval-mozilla-beta+
Attachment #808817 - Flags: review?(blassey.bugs)
Comment on attachment 808700 [details] [diff] [review]
release_use_common.patch

I think we're good here; thanks everyone.
Attachment #808700 - Flags: review?(hwine)
Attachment #808700 - Flags: review?(aki)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Oops, I think we need to land this on Aurora+Central.

https://hg.mozilla.org/releases/mozilla-beta/rev/d0248e4d4357
Comment on attachment 808815 [details] [diff] [review]
mozconfig.diff

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Previous mozconfig changes

User impact if declined: 
27.0b1 will fail the same way

Testing completed (on m-c, etc.): 
Same patch made 25.0b2+ work without mozconfig issues.

Risk to taking this patch (and alternatives if risky):
Low.
 
String or IDL/UUID changes made by this patch:
None.
Attachment #808815 - Flags: approval-mozilla-aurora?
Inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/7d1973314652

If that sticks and makes it to Central, we're covered for 28.0b1+.  We still need to land on Aurora to avoid hitting this on 27.0b1.
Attachment #808815 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.