wiki.page() inclusion seems to do weird things

RESOLVED DUPLICATE of bug 834055

Status

developer.mozilla.org
General
RESOLVED DUPLICATE of bug 834055
5 years ago
4 years ago

People

(Reporter: a.d.bergi, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

5 years ago
What did you do?
================
Check the page https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Function#Function_instances. It does include the /prototype subpage, specifically the sections "Properties" and "Methods"

What happened?
==============
1. Using the Template:Page <https://developer.mozilla.org/en-US/docs/Template:page> via

{{page('/en-US/docs/JavaScript/Reference/Global_Objects/Function/prototype', 'Properties')}}

it does include the section "Methods", not "Properties" - making it appear tice in the end

2. The included pages include deprecation warning badges (via some templates). The opening tag <i class="icon-warning-sign"> is repeated after the template-following </dt> tag, seemingly during the inclusion process. It now invalidates the whole page markup due to inproperly closed tags, applying its CSS to all the following text.

What should have happened?
==========================
The subpage should have been included properly.

Is there anything else we should know?
======================================

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 834055
You need to log in before you can comment on or make changes to this bug.