Closed Bug 918581 Opened 6 years ago Closed 6 years ago

Extend merge-profile.py to support secondary threads

Categories

(Core :: Gecko Profiler, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: BenWa, Assigned: BenWa)

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

Right now it will merge the first thread only.

Sotaro I wrote a patch on your machine, can you attach it?
Flags: needinfo?(sotaro.ikeda.g)
BenWa, thanks for your help today! This is the patch.
Flags: needinfo?(sotaro.ikeda.g)
Today, You helped me to profile Camera app start up. I misunderstood about b2g master's profile setting. On b2g master, the profile is disabled by default. After enabling it, I seems to get correct profile data.
https://github.com/mozilla-b2g/gonk-misc/blob/master/default-gecko-config#L20

And Confirmed that GonkCameraHardware::Connect() is correctly called on camera thread by a custom log. New profile result also correctly catch the function call.
Assignee: nobody → bgirard
Attachment #807540 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #807576 - Flags: review?(vladimir)
https://hg.mozilla.org/mozilla-central/rev/ae2e03b1b340
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Do we need to uplift this to aurora?
Flags: needinfo?(bgirard)
I don't need it on aurora but it could come in handy. There's zero product regression risk here.
Flags: needinfo?(bgirard)
Comment on attachment 807576 [details] [diff] [review]
patch - support secondary threads

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 915857
User impact if declined: None
Testing completed (on m-c, etc.): used for perf analysis on m-c
Risk to taking this patch (and alternatives if risky): None, patches script used during manual performance analysis. Not part of the build or tests.
String or IDL/UUID changes made by this patch: None
Attachment #807576 - Flags: approval-mozilla-aurora?
Comment on attachment 807576 [details] [diff] [review]
patch - support secondary threads

a=nptob
Attachment #807576 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Thank you for landing Ryan!
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.