Add a filtering option to the Browser Console to not display things from content.

RESOLVED DUPLICATE of bug 860705

Status

()

Firefox
Developer Tools: Console
RESOLVED DUPLICATE of bug 860705
4 years ago
4 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Using the web console, I get an easy view of messages and errors from only the web page I'm viewing.

But if I open the browser console, I get a cluttered view of everything from chrome and content (from all tabs/windows).

It'd be nice to have a checkbox or something I can toggle to hide all of the things coming from web content, so I get a view of *only* things coming from chrome. (Or maybe a three-way toggle between displaying everything/chrome/content?)

My use case for when I'm working on a browser feature or an extension, I have the browser console open to see logging for whatever I'm working on. I have an error or message displayed in the console that I'm referencing. But if I have a tab open to something that repeatedly sends out requests to the network, it can spam the console with unrelated messages, pushing the thing I actually care about out of view. I then have to scroll around to find it again. (And at some point, it gets pushed out of the console completely, though I'm unsure if this point could be fixed by just not displaying the things coming from web content, since they'd still exist, just not shown...)

If I could hide the messages coming from content, the error/message that I care about stays where it is until something else from chrome (which I might be interested in) gets logged, pushing it up.
Thanks for the bug report. We already have a bug open about not displaying messages from tabs in the browser console - see bug 860705.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 860705
You need to log in before you can comment on or make changes to this bug.