If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Startup issue since upgrade to FF release 24.

RESOLVED DUPLICATE of bug 918276

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 918276
4 years ago
4 years ago

People

(Reporter: John Kitz, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 807653 [details]
startup-since-release24.JPG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

1. Click the FF icon to start FF.


Actual results:

In one out of two to three of the start-ups FF starts up with the error message shown in the screenshot in the attachment.


Expected results:

FF should have started with the about:newtab page.

Comment 1

4 years ago
Does it only happen if you close all tabs before shutting down Firefox? If so, it might be the same issue as bug 918276.

In about:config, please confirm what these two entries are set to:

browser.startup.page
browser.tabs.closeWindowWithLastTab

Updated

4 years ago
Flags: needinfo?(John.Kitz)
(Reporter)

Comment 2

4 years ago
(In reply to mjh563 from comment #1)
> Does it only happen if you close all tabs before shutting down Firefox? If
> so, it might be the same issue as bug 918276.

Had a quick look at bug 918276. They appear to be similar. Not sure if they are exactly the same. For one I can't reproduce it reliably, but that may very well be attributable to less tinkering with profiles and settings on my part.

> In about:config, the following two entries are set as follows:

browser.startup.page                default integer 1
browser.tabs.closeWindowWithLastTab default boolean true
(Reporter)

Updated

4 years ago
Flags: needinfo?(John.Kitz)
Component: Untriaged → Session Restore

Comment 3

4 years ago
(In reply to John Kitz from comment #2)
> > In about:config, the following two entries are set as follows:
> 
> browser.startup.page                default integer 1
> browser.tabs.closeWindowWithLastTab default boolean true

John, thanks! Those prefs are set to the default, which puzzled me (other reports of this bug have had non-default prefs), but I've now found that it's also reproducible with default prefs.

So I'm going to resolve this as a duplicate of bug 918276, because I'm almost sure it's the same bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918276
(Reporter)

Comment 4

4 years ago
> John, thanks! Those prefs are set to the default, which puzzled me (other
> reports of this bug have had non-default prefs), but I've now found that
> it's also reproducible with default prefs.
> 
Please note that the error also occurs without even having had a single tab loaded with a website. What I do not have set to default and which might be related to this is Tools -> Options -> General -> Homepage, which I have set to about:newtab.
(Reporter)

Comment 5

4 years ago
> John, thanks! Those prefs are set to the default, which puzzled me (other
> reports of this bug have had non-default prefs), but I've now found that
> it's also reproducible with default prefs.
> 
Should it be useful I've also set Tools -> Options -> General -> When Firefox starts to "Show my home page".
You need to log in before you can comment on or make changes to this bug.