offline mode: POST DATA warning in form submission [form sub]

VERIFIED FIXED in Future

Status

()

P4
normal
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: bugzilla3, Assigned: alexsavulov)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: checkmac checkwin)

(Reporter)

Description

18 years ago
build 2001072003, Win95/98:
1. Enter some Bugzilla bug report page
2. Go offline
3. Press "Commit"

A dialog box warning says : The page you are trying to view contains POSTDATA
that has expired from cache..." and asks for confirmation. It is confusing and
one can't get out of this unless he remembers to come back in online mode.
<erasing earlier comments> Ok, confirming this.  I just went offline and was
unable to submit this form with an alternate set of comments.

Over to form submission.  Platform -> All, OS -> All
Assignee: asa → rods
Status: UNCONFIRMED → NEW
Component: Browser-General → Form Submission
Ever confirmed: true
OS: Windows 95 → All
QA Contact: doronr → vladimire
Hardware: PC → All

Comment 2

17 years ago
Over to eric
Assignee: rods → evaughan

Comment 3

17 years ago
to forms
Assignee: evaughan → alexsavulov
(Assignee)

Comment 4

17 years ago
Should we change the text to warn the user that he's in offline mode?
(Reporter)

Comment 5

17 years ago
*** Bug 114591 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Summary: offline mode: POST DATA warning in form submission → offline mode: POST DATA warning in form submission [from sub]
This also occurs with expired POST cache.

You should be able to hit cancel, hit back, and have it skip the bad page and go
to the one before it.

BTW - why does the POST cache expire so quickly?
(Assignee)

Comment 7

17 years ago
summary correction
Summary: offline mode: POST DATA warning in form submission [from sub] → offline mode: POST DATA warning in form submission [form sub]
Notice that NS 6.2 does skip the offending page. I'm wondering if older versions
of Mozilla did. This might be a regression.
(Assignee)

Comment 9

17 years ago
setting milestone
Target Milestone: --- → Future

Comment 10

17 years ago
test

Updated

17 years ago
Priority: -- → P4
(Reporter)

Comment 11

17 years ago
*** Bug 157428 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 162291 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Here's a related one:

1. Go offline.
2. Visit Google (www.google.com), forgetting that you're offline
   (in the case, I was dialed in but forgot the browser was offline)
3. Browser has loaded cached page from Google
4. Type in search terms and press Submit. You get the submitting form
   data over unencrypted connection warning, but nothing happens.

Mozilla should warn users when submitting forms offline that the browser is
offline  and that form submissions will not work.
The patch in bug 45421 fixed this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Depends on: 45421
Resolution: --- → FIXED

Comment 15

15 years ago
V: Mozilla 1.6f, linux.
Status: RESOLVED → VERIFIED
QA Contact: vladimire → benc
Whiteboard: checkmac checkwin
You need to log in before you can comment on or make changes to this bug.