[XHR2] Returns real statusText for a failed redirect even when it's considered a network error

RESOLVED DUPLICATE of bug 716491

Status

()

RESOLVED DUPLICATE of bug 716491
5 years ago
4 years ago

People

(Reporter: hsteen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
Test case:
http://w3c-test.org/web-platform-tests/master/XMLHttpRequest/send-redirect-bogus.htm 

Last test fails with output:
assert_equals: expected "" but got "WEBSRT MARKETING"

Test returns a bogus redirect like 

HTTP/1.1 303 WEBSRT MARKETING
Location: foobar:someone@example.org

Per spec, when the error flag is set, statusText should return the empty string.
Fixed by patch in bug 716491.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 716491
You need to log in before you can comment on or make changes to this bug.