Closed Bug 918778 Opened 6 years ago Closed 6 years ago

[Inari][Buri] Gallery crashing when tapping save button

Categories

(Core :: Graphics, defect)

26 Branch
Other
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED WORKSFORME
blocking-b2g koi+

People

(Reporter: zcampbell, Assigned: sotaro)

References

Details

(Keywords: crash, regression)

Crash Data

STR
1. Push an image to the SD card
2. Load gallery
3. Load the image
4. Edit the image
5. Navigate through all the edit options
6. Tap on Save
7. Gallery will crash/close, user is returned to Homescreen

*There is no crash report! *

Device Inari
Gecko  http://hg.mozilla.org/mozilla-central/rev/803189f35921
Gaia  676a9f08a8eacdfc47286ca1e24bf1f99faaf318
BuildID 20130919040201
Version 27.0a1


Logcat:


I/Gecko   ( 1006): 1379677153263	Marionette	TRACE	Got: {"element": "{780e3319-8429-4fc2-a8dc-622a0f30af9b}", "to": "0", "session": "6-b2g", "y": null, "x": null, "type": "singleTap"}
I/Gecko   ( 1109): 1379677153293 Marionette: emitting Touch event of type touchstart to element with id: edit-save-button and tag name: BUTTON at coordinates (295, 25) relative to the viewport
I/Gecko   ( 1109): 1379677153297 Marionette: emitting Touch event of type touchend to element with id: edit-save-button and tag name: BUTTON at coordinates (295, 25) relative to the viewport
I/Gecko   ( 1109): 1379677153303 Marionette: emitting Mouse event of type mousemove at coordinates (295, 25) relative to the viewport
I/Gecko   ( 1109): 1379677153306 Marionette: emitting Mouse event of type mousedown at coordinates (295, 25) relative to the viewport
I/Gecko   ( 1109): 1379677153314 Marionette: emitting Mouse event of type mouseup at coordinates (295, 25) relative to the viewport
I/Gecko   ( 1109): OpenGL version detected: 200
I/Gecko   ( 1109): SharedSurface_Gralloc::Create -------
I/Gecko   ( 1109): SharedSurface_Gralloc::Create: success -- surface 0x47f31dc0, GraphicBuffer 0x43a78f80.
I/Gecko   ( 1006): [Parent 1006] WARNING: pipe error (102): Connection reset by peer: file ../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 437
I/Gecko   ( 1006): [Parent 1006] WARNING: pipe error (117): Connection reset by peer: file ../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 437
I/Gecko   ( 1006): 
I/Gecko   ( 1006): ###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv
I/Gecko   ( 1006): 
E/GeckoConsole( 1006): [JavaScript Error: "[Exception... "'Error: no message manager set' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]"]
I/Gecko   ( 1006): 
I/Gecko   ( 1006): ###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv
I/Gecko   ( 1006): 
E/GeckoConsole( 1006): [JavaScript Error: "[Exception... "'Error: no message manager set' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]"]
E/GeckoConsole( 1171): Could not read chrome manifest 'file:///system/b2g/chrome.manifest'.
I/Gecko   ( 1171): ###################################### forms.js loaded
I/Gecko   ( 1171): ############################### browserElementPanning.js loaded
I/Gecko   ( 1171): ######################## BrowserElementChildPreload.js loaded
E/GeckoConsole( 1171): [JavaScript Warning: "Unknown property 'box-sizing'.  Declaration dropped." {file: "app://homescreen.gaiamobile.org/style/grid.css" line: 219 column: 19 source: "         box-sizing: border-box;"}]
I/Gecko   ( 1171): MobileConnection initialized
When the first time this test failed? Can you give an explicit regression range?
blocking-b2g: --- → koi?
I can't immediately because we've had our Unagi builds borked for a week and we've had limited capacity on the Inari which we started testing on late.

We'd have to go back over the nightly builds to get the range which I can't get to immediately, it is late Friday here already!
(In reply to Zac C (:zac) from comment #2)
> I can't immediately because we've had our Unagi builds borked for a week and
> we've had limited capacity on the Inari which we started testing on late.
> 
> We'd have to go back over the nightly builds to get the range which I can't
> get to immediately, it is late Friday here already!

Okay, we'll likely have to see if we can reproduce this manually & get the regression window that way.
QA Contact: sparsons
I can reproduce this issue back to the 8/10 Buri 1.2 Build ID: 20130810040220

Environmental Variables
Build ID: 20130810040220
Gecko: http://hg.mozilla.org/mozilla-central/rev/c5946a8bcd5b
Gaia: 2814f1df7dd77590250aef0035704e60428765ff
Platform Version: 26.0a1
RIL Version: 01.01.00.019.197 


Last working 8/09 Buri 1.2 Build ID: 20130809040201

Environmental Variables
Build ID: 20130809040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e33c2011643e
Gaia: c354940fbe112bcf2d90e2a5654ad1824f3a2348
Platform Version: 26.0a1
RIL Version: 01.01.00.019.197 

I followed the STR in Comment 0 and obtain this Crash report: https://crash-stats.mozilla.com/report/index/d3504a38-4a40-4824-a746-851942130924
Crash Signature: [@ BackstagePass::GetClassID(nsID**)]
I haven't yet been able to reproduce this crash on my Buri device using:

Gaia   b0e4a1333bb7bf0a749a384ba99e4f03f111e39a
SourceStamp fb764e648a8f
BuildID 20130925004005
Version 26.0a2
Keywords: crash
Summary: [Inari] Gallery crashing when tapping save button → [Inari][Buri] Gallery crashing when tapping save button
blocking-b2g: koi? → koi+
Reproducible on inari with:
- gecko: aurora:cd4ec57115ab
- gaia: v1.2:a13c76f8d3c617ee57c302c103da04ed1a6298d1
blocking-b2g: koi+ → koi?
I'm assuming you didn't mean to renom that.
blocking-b2g: koi? → koi+
Blocks: GFXB2G1.2
Component: Gaia::Gallery → Graphics
Product: Boot2Gecko → Core
Version: unspecified → 26 Branch
(In reply to Sarah Parsons from comment #4)
> I followed the STR in Comment 0 and obtain this Crash report:
> https://crash-stats.mozilla.com/report/index/d3504a38-4a40-4824-a746-
> 851942130924

From the above report, the crash happen as a side effect of ipc failure. In this bug, there  is no information of why ipc failure happened. I tried to reproduce it by using master hamachi, but I can not reproduce it.
Assigning to Sotaro, but can somebody reproduce on hamachi?
Assignee: nobody → sotaro.ikeda.g
I already tried several times, but I still can't reproduce the problem.
(In reply to Sotaro Ikeda [:sotaro] from comment #10)
>
> I already tried several times, but I still can't reproduce the problem.

To reproduce this issue on inari, step 5 in comment 0 seemed to be important.
(In reply to Marcia Knous [:marcia] from comment #5)
> I haven't yet been able to reproduce this crash on my Buri device using:
> 
> Gaia   b0e4a1333bb7bf0a749a384ba99e4f03f111e39a
> SourceStamp fb764e648a8f
> BuildID 20130925004005
> Version 26.0a2

About the above, the following change might affected. 
- Bug 905784 - /system/build.prop do not have 'debug.sf.hw=1' on moz built ROM for hamachi(buri) and leo

On ROMs in Comment 4 and Comment 6, gralloc buffers can be fall back from pmem to ashmem. But the above ROM can not fallback.
zac, can you re-generate the crash by using resent v1.2 buri/hamachi ROM? If you can re-generate the crash by the ROM, can you get "adb shell dmesg" log?
Flags: needinfo?(zcampbell)
The crash might happen by similar mechanism as in Bug 894826.
Hi Sotaro, I lent my Hamachi out but if you leave the needinfo then I can check it on the weekend. 

In the meantime if anybody else can check as per comment #13 then please clear my needinfo :)
(In reply to Zac C (:zac) from comment #15)
> Hi Sotaro, I lent my Hamachi out but if you leave the needinfo then I can
> check it on the weekend. 
> 
> In the meantime if anybody else can check as per comment #13 then please
> clear my needinfo :)

Thanks!
Ikeda-san, I checked on:

Gecko  http://hg.mozilla.org/releases/mozilla-aurora/rev/f067799dff06
Gaia  85c4af3f48a91878d565f518ba0eed68f0628e21
BuildID 20131007004003
Version 26.0a2
Device Hamachi

All is fine now :)
Flags: needinfo?(zcampbell)
No longer blocks: b2g-central-dogfood
Marking this resolved WFM given comment #17, please re-open if needed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.