Closed Bug 918819 Opened 6 years ago Closed 6 years ago

Fix bustage from Bug 917295 (GC: Handlify public date APIs)

Categories

(Calendar :: Internal Components, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

Attachments

(1 file)

Error message while building:

c:/t1/hg/comm-central/calendar/base/backend/libical/calDateTime.cpp(625) : error C2664: 'JS_ObjectIsDate' : cannot convert parameter 2 from 'JSObject *' to 'JS::HandleObject'
No constructor could take the source type, or constructor overload resolution was ambiguous
Attachment #807750 - Flags: review?(philipp)
Comment on attachment 807750 [details] [diff] [review]
Patch v1.0 first attempt to fix bustage.

I have no idea what I'm doing so I'll CC the person who worked on Bug 917295
Attachment #807750 - Flags: review?(jcoppeard)
Comment on attachment 807750 [details] [diff] [review]
Patch v1.0 first attempt to fix bustage.

Review of attachment 807750 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine.
Attachment #807750 - Flags: review?(jcoppeard) → review+
Pushed bustage fix to comm-central
Leaving open for ex post facto review from Lightning peer.
Comment on attachment 807750 [details] [diff] [review]
Patch v1.0 first attempt to fix bustage.

Thanks for the patch and review! I would have been fine with only one review, but the code looks fine. r=philipp
Attachment #807750 - Flags: review?(philipp) → review+
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.9
Oops forgot to link to the pushed changeset:
https://hg.mozilla.org/comm-central/rev/a5925d4f1670
Duplicate of this bug: 868483
You need to log in before you can comment on or make changes to this bug.