javascript strict warnings in walletTasksOverlay.xul

VERIFIED FIXED

Status

()

Toolkit
Form Manager
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
To reproduce:
1) Start Mozilla
2) Start the JavaScript console
3) load http://mozilla.org
4) Select Tasks -> Privacy -> Cookies -> Unblock from this site
5) Switch to the console
6) Select Tasks -> Privacy -> Password Manager

Warning: reference to undefined property this.pref
Source File: chrome://wallet/content/walletTasksOverlay.xul
Line: 45

build 20010721

Comment 1

17 years ago
I'm wondering why we even have chrome on the javascript consule.  But, assuming 
that there is good reason for having that, at least we shouldn't have the 
password manager in the task menu of the java console (we already remove the 
form-manager in that case).

Attaching patch that removes the password manager as well as the form manager.  
cc'ing vishy and blake for reviews.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.3

Comment 2

17 years ago
Created attachment 43218 [details] [diff] [review]
remove password manager from javascript console chrome

Comment 3

17 years ago
Why do we want to remove it? I thought the purpose of the Tasks menu was to be
consistent everywhere.

Comment 4

17 years ago
And the image manager is not to appear in the Netscape product unless told to do 
so by a hidden pref.  But you can't test for prefs when in the javascript 
console window.  So therefore the task menu cannot be the same in the browser 
and the javascript console.  That's why I opted to fix this bug by removing the 
items.  See also bug 91881 where first I tried keeping the items in but quickly 
ran into trouble.

Comment 5

17 years ago
If we really want to keep these items in the task menu (in fact, if we really 
want to keep the task menu) in the js-console window, then here's a patch that 
fixes the js bugs without changing the menu items.

Note that this module already had code in it which removed the form-manager from 
the task menu when not in the browser window.  I believe that that was requested 
at one time by the mail team (but I'm not sure) because it was causing problems 
in the mail window.  So now if we want to keep the task menu the same in all 
windows, I must remove that form-manager-removal code.  My next patch does that 
as well.

Comment 6

17 years ago
Created attachment 43443 [details] [diff] [review]
fix js errors without removing menu items
r=vishy

Comment 8

17 years ago
Created attachment 43486 [details] [diff] [review]
anticipating blake's comments (based on his comments in bug 91881)

Comment 9

17 years ago
should null check pref in some of those places.... sr=blake

Comment 10

17 years ago
Created attachment 43489 [details] [diff] [review]
added null check for pref

Comment 11

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
Verified fixed w2k build 2001081003
Status: RESOLVED → VERIFIED

Updated

10 years ago
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
Target Milestone: mozilla0.9.3 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.