Closed Bug 918853 Opened 6 years ago Closed 6 years ago

Existing Thunderbird profile is no longer offered for import in a first-run situation

Categories

(SeaMonkey :: Startup & Profiles, defect, major)

defect
Not set
major

Tracking

(seamonkey2.22 unaffected, seamonkey2.23 verified, seamonkey2.24 fixed)

VERIFIED FIXED
seamonkey2.24
Tracking Status
seamonkey2.22 --- unaffected
seamonkey2.23 --- verified
seamonkey2.24 --- fixed

People

(Reporter: rsx11m.pub, Assigned: ewong)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

 1. Make sure to have a Thunderbird profile folder in AppData (Windows)
    or ~/.thunderbird (Linux)

 2. Rename the Mozilla (~/.mozilla) folder to trigger first-run situation

 3. Start SeaMonkey

Expected behavior:

 4. Import Wizard shows up, offering import of the Thunderbird profile

Actual behavior:

 4. Browser with start page shows up directly without the Import Wizard
    being invoked

This regression was introduced some time during the 2.23a1 cycle.
Actually, quite early into the previous cycle:

  Last working 2.23a1 build: 2013-08-06
  First broken 2.23a1 build: 2013-08-07

http://hg.mozilla.org/comm-central/pushloghtml?startdate=2013-08-06&enddate=2013-08-07

Bug 739056 - "Port |Bug 715099 - Convert nsProfileMigrator to JS so we can use JS modules on migration| to SeaMonkey" looks like a matching candidate for this regression?
Flags: needinfo?(ewong)
Blocks: 739056
(In reply to rsx11m from comment #1)
> Actually, quite early into the previous cycle:
> 
>   Last working 2.23a1 build: 2013-08-06
>   First broken 2.23a1 build: 2013-08-07
> 
> http://hg.mozilla.org/comm-central/pushloghtml?startdate=2013-08-
> 06&enddate=2013-08-07
> 
> Bug 739056 - "Port |Bug 715099 - Convert nsProfileMigrator to JS so we can
> use JS modules on migration| to SeaMonkey" looks like a matching candidate
> for this regression?

Probably.  I'm looking into this.  I just need to build a recent tree.
Flags: needinfo?(ewong)
Thanks (and there is a typo in the bug summary, correcting that).
Summary: Existing Thunderbird profile is now longer offered for import in a first-run situation → Existing Thunderbird profile is no longer offered for import in a first-run situation
Firefox migrator Bug 715099 had the same problem. One of the dependencies of that bug is:
Bug 724808 (First run import wizard doesn't show up on Firefox 12 and 13). Ewong just needs to port https://hg.mozilla.org/mozilla-central/rev/f0cc27e3731c
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #810911 - Flags: review?(bugspam.Callek)
Attachment #810911 - Attachment description: Proposted patch (v1) → Proposed patch (v1)
Comment on attachment 810911 [details] [diff] [review]
Proposed patch (v1)

Frank probably has more time to do reviews. r? => mcsmurf
Attachment #810911 - Flags: review?(bugzilla)
Blocks: 925803
Comment on attachment 810911 [details] [diff] [review]
Proposed patch (v1)

Yeah, looks good. Remember to land this on aurora as well.
Attachment #810911 - Flags: review?(bugzilla)
Attachment #810911 - Flags: review?(bugspam.Callek)
Attachment #810911 - Flags: review+
Comment on attachment 810911 [details] [diff] [review]
Proposed patch (v1)

[Approval Request Comment]
Regression caused by (bug #): Bug 739056
User impact if declined:  Existing Thunderbird profile is no longer offered for import in a first-run situation
Testing completed (on m-c, etc.): working on CC 
Risk to taking this patch (and alternatives if risky): Low to none (buildconfig change)
String changes made by this patch: None.
Attachment #810911 - Flags: approval-comm-aurora?
Target Milestone: --- → seamonkey2.24
Keywords: checkin-needed
Attachment #810911 - Flags: approval-comm-aurora? → approval-comm-aurora+
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/f62a973749f7
Pushed to comm-aurora:
http://hg.mozilla.org/releases/comm-aurora/rev/ddb6e3745674
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Verified fixed Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 SeaMonkey/2.23a2
Build identifier: 20131019013001.
Status: RESOLVED → VERIFIED
Blocks: 947616
No longer blocks: 947616
See Also: → 947616
You need to log in before you can comment on or make changes to this bug.