[B2G][SMS] User is not prompted to choose a phone number when the contact has two numbers

RESOLVED INVALID

Status

Firefox OS
Gaia::SMS
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected)

Details

Attachments

(1 attachment)

Created attachment 807853 [details]
logcat

Description:
The user is not prompted which phone number to send the SMS to when the contact has two phone numbers.

Repro Steps:
1)  Updated to Buri Build ID: 20130916040205
2)  Create a contact that has two phone numbers.
3)  Tap the "SMS" icon to open messaging.
4)  Tap the "Compose New Email" icon.
5)  Tap on the "+" icon to add a contact.
6)  Select the contact that has two phone numbers.

Actual:
The user is not prompted which number to send the SMS to when the contact has multiple phone numbers.

Expected:
The user is prompted to select a phone number when sending a SMS to a contact with multiple numbers.

Environmental Variables
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
Repro frequency: (100%)
Test Suite Name: (SMS)
UCID: (messages-001)
Link to failed test case: https://moztrap.mozilla.org/manage/case/5018/
See attached: (logcat)
This is an invalid bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Whiteboard: burirun1
ktucker> could you please explain why this is invalid, for future reference ?
Flags: needinfo?(ktucker)
I had the second phone number in the wrong field (carrier) so i thought i was seeing an issue but this wasn't the case. Once i populated the number in the correct phone number field, everything functioned as intended.
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.