Closed Bug 918950 Opened 6 years ago Closed 6 years ago

API policy and technology need to evolve with new profile features

Categories

(Participation Infrastructure :: Phonebook, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1011209

People

(Reporter: hoosteeno, Unassigned)

References

(Blocks 1 open bug)

Details

The Mozillians profile has evolved. We now have field privacy levels, including levels that are intended to be visible to only a subset of Mozillians ("privileged"). But the API currently does not communicate field privacy levels to its consumers, so that they could enforce them; and it currently does not enforce them itself. That means API consumers can retrieve privileged fields without knowing they are privileged fields.

We need to...

a) develop and publish better guidelines about the use of Mozillians.org API data
b) build field privacy levels into the Mozillians.org API 

This is becoming ever more urgent.
We've turned the problem statement in Comment 0 into a set of affirmative specs covered by tracking bug 1011209. Closing this as a duplicate.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1011209
Bumping to verified duplicate per comment 1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.