redrawing DHTML window affects others in this website (dhtmlcentral.com)

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
--
critical
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: yoav, Assigned: jst)

Tracking

({dom0, regression})

Trunk
mozilla1.1alpha
dom0, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

the windows don't drag as well as in ie 5.
you get this blue trail.

Reproducible: Always
Steps to Reproduce:
1.drag one of the windows


Actual Results:  blue trail

Comment 1

17 years ago
Attach the screenshot of the problem you are seeing, because that page works
PERFECTLY for me.
I really dont understand what you mean with "drag the windows"

Comment 2

17 years ago
Confirming in 2001072304 trunk for MacOS.
Dragging the DHTML windows at the top causes the window frame color to over flow
into the second row windows.
All/All
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM HTML
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: drag the windows in this website and see the bug → redrawing DHTML window affects others in this website

Comment 3

17 years ago
Created attachment 43264 [details]
here's a screenshot
There was a "WindowScript" that you needed to click on.  It was a JS popup, but
I grabbed the link address and updated the URL here to reflect it.

By the way, on Linux 2001072306 I don't see any mangling of the boxes.  No blue
trail, but not what the screenshot shows.

Comment 5

17 years ago
Oh, well. The URL has a different source script now. Need to find an appropriate
one for this bug.

Comment 6

17 years ago
Updated the URL

Comment 7

17 years ago
really moving
Assignee: asa → jst
QA Contact: doronr → stummala
(Reporter)

Comment 8

17 years ago
with build 0.9.3 this bug was fixed but now with build 2001083103 this bug is
back :)

Comment 9

17 years ago
confirmed on win 2000
(Reporter)

Comment 10

17 years ago
also, when moving or resizing the windows everything moves really slow. i
experienced this problem with other sites which had extensive dhtml use.
with ie5 it works perfect.

build 2001091003
win2000

Updated

17 years ago
Keywords: dom0, regression
(Reporter)

Comment 11

17 years ago
now, with build 2001092003, the site is completely ruined.

Comment 12

16 years ago
the same (ruined) with build 2001111008 on win2k.
any clues so far? This is one of the most visited
sites in the DHTML community.
Severity: normal → major
Keywords: mozilla0.9.7, nsCatFood

Updated

16 years ago
Summary: redrawing DHTML window affects others in this website → redrawing DHTML window affects others in this website (dhtmlcentral.com)

Comment 13

16 years ago
This is crazy. Only the top banner loads in 0.9.5. Raising severity.
Might this be a networking issue?
Also adding this bug to my DOM bugs for Mozilla 1.0 list.
Severity: major → critical
(Assignee)

Comment 14

16 years ago
I'd be surprised if this is a bug in our code, I didn't look at the code yet,
but it smells like evang to me. Any help with debugging the HTML on this site
would be creatly appreciated.
Target Milestone: --- → mozilla0.9.8
For testers, bug 109754 should be fixede in tomorrow's build, so you can
actually see the site again :)

Comment 16

16 years ago
found this style rule on the page

body {overflow:auto;}

seems to be causing the body to be small (that is why only the top part of the
page is visible). When I set it to overflow: hidden; it fixes that part of the
issue. Try putting this in the URL bar and press Enter:

javascript: void(document.body.style.overflow="hidden");


Besides this, the "redrawing problem" (the original problem reported) is still
there. It seems to only affect the top 3 "windows". I think it is because the
"windows" the content of those windows are actually overflowing out of the
"window". Note that when one "scroll" to the bottom it doesnot affect the
"windows" below it.

build 2001112803 win32
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 17

16 years ago
Also see bug 95105. Kind of same bug, possibly a duplicate.
(Assignee)

Comment 18

16 years ago
Pushing out to mozilla1.1.
Target Milestone: mozilla0.9.9 → mozilla1.1

Comment 19

16 years ago
Just like bug 95105, this is WFM in 2002030412 trunk for MacOS9.x
Reopen if it persists.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.