If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Email fails to start properly

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: fabrice, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
On a current master build, we're stuck on a blank page. Relevant logcat:
I/Gecko   ( 3588): WLOG: Email knows that it is: online and previously was: online
I/Gecko   ( 3588): WLOG: deferring getConfig call until ready
I/Gecko   ( 3588): WLOG: main thread reports DB ready
I/Gecko   ( 3588): WLOG: issuing getConfig call to main thread
I/Gecko   ( 3588): WLOG: cronsync: ensureSync called
I/Gecko   ( 3588): 
I/Gecko   ( 3588): WLOG: Mail universe/bridge created and notified!
I/GeckoDump( 3588): LOG: cronsync-main: ensureSync called
I/Gecko   ( 3588): WLOG: cronsync: received an syncEnsured via a message handler
I/Gecko   ( 3588): 
I/GeckoDump( 3588): ERR: onerror reporting: Error: js/cards/setup_account_info.html HTTP status: 500 @ app://email.gaiamobile.org/js/mail_app.js : 7374
E/GeckoConsole( 3588): [JavaScript Error: "Error: js/cards/setup_account_info.html HTTP status: 500" {file: "app://email.gaiamobile.org/js/mail_app.js" line: 7374}]
E/GeckoConsole( 3680): Could not read chrome manifest 'file:///system/b2g/chrome.manifest'.
I/Gecko   ( 3680): ###################################### forms.js loaded
I/Gecko   ( 3680): ############################### browserElementPanning.js loaded
I/Gecko   ( 3680): ######################## BrowserElementChildPreload.js loaded
I/GeckoDump( 3588): ERR: onerror reporting: Error: Timeout for modules: cards/setup_account_info,tmpl!cards/setup_account_info.html @ app://email.gaiamobile.org/js/mail_app.js : 1064
E/GeckoConsole( 3588): [JavaScript Error: "Error: Timeout for modules: cards/setup_account_info,tmpl!cards/setup_account_info.html" {file: "app://email.gaiamobile.org/js/mail_app.js" line: 1064}]
On a 9/20 build 1.2 build, I'm not seeing this. That likely implies this is a regression from something that landed today.

Updated

4 years ago
blocking-b2g: --- → koi?
Keywords: regression
I just tried grabbing latest gaia master on my older build of gecko, and that works. However, when I update to latest nightly gecko it fails, so I suspect a change in gecko. The important error is this one:

I/GeckoDump(  734): ERR: onerror reporting: Error: js/cards/setup_account_info.html HTTP status: 500 @ app://email.gaiamobile.org/js/mail_app.js : 7374

So, apparently when the app does an XHR for the card HTML, it is now getting an error 500. I am not sure what change in gecko caused this, and I have limited access to my full computer today, but hopefully this helps narrow down the problem.

Maybe a change around CORS rules, or XHR calls to app: domains? Just guessing though.

This failure affects the integration tests, so it is hard to land other Gaia changes because of it -- Kevin Grandon found his Gaia pull requests are failing their travis runs because of it.
Looks like setting responseType = 'text' on the xhr fixes it, so doing a quick patch for that and will land it quickly.
Created attachment 808359 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12354

Pointer to Github pull-request
Comment on attachment 808359 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12354

xhr.responseType = 'text' is needed to fix running on latest gecko. Going to wait for travis to complete, but then will likely land myself immediately given that it blocks others from submitting passing pull requests for gaia as the integration tests fail, and the change is very straightforward.
Travis has a failing unit test, but that is in browser, not email, and while the integration test did not complete, it looks like the intermittent failure seen on travis, and the problem reported in this bug is fixed, so going to merge to master.
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/49a0da45de783c96fb8e49bbc7f1c395d5da9273

from pull request:
https://github.com/mozilla-b2g/gaia/pull/12354
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I just did a fresh master build and this is still happening on my unagi with a BRANCH=master build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The following is the 'adb logcat' for the e-mail app invocation:

I/Gonk    (  108): Setting nice for pid 428 to 1
I/Gonk    (  108): Changed nice for pid 428 from 18 to 1.
D/memalloc(  108): /dev/pmem: Allocated buffer base:0x48900000 size:614400 offset:5816320 fd:115
D/memalloc(  108): /dev/pmem: Allocated buffer base:0x48900000 size:614400 offset:6430720 fd:123
E/GeckoConsole(  428): [JavaScript Warning: "Error in parsing value for '-moz-transition-delay'.  Declaration dropped." {file: "app://email.gaiamobile.org/style/mail.css" line: 1639 column: 25 source: "  -moz-transition-delay: 0;"}]
E/GeckoConsole(  428): [JavaScript Warning: "Error in parsing value for 'transition'.  Declaration dropped." {file: "app://email.gaiamobile.org/style/mail.css" line: 1642 column: 14 source: "  transition: translateX(0);"}]
E/GeckoConsole(  428): [JavaScript Warning: "Error in parsing value for 'background-image'.  Declaration dropped." {file: "app://email.gaiamobile.org/style/mail.css" line: 1680 column: 20 source: "  background-image: -webkit-gradient(linear, left top, left bottom, color-stop(0%,  #cc6523), color-stop(100%, #bb492d));"}]
E/GeckoConsole(  428): [JavaScript Warning: "Expected end of value but found 'height'.  Error in parsing value for 'top'.  Declaration dropped." {file: "app://email.gaiamobile.org/style/mail.css" line: 1702 column: 2 source: "  height: 5.2rem;"}]
E/GeckoConsole(  428): [JavaScript Warning: "Unknown property 'box-sizing'.  Declaration dropped." {file: "app://email.gaiamobile.org/style/mail.css" line: 2394 column: 12 source: "  box-sizing: border-box;"}]
E/GeckoConsole(  428): [JavaScript Warning: "Error in parsing value for 'background'.  Declaration dropped." {file: "app://email.gaiamobile.org/style/mail.css" line: 2540 column: 50 source: "  background: transparent no-repeat top left 100% 100%;"}]
E/GeckoConsole(  428): [JavaScript Warning: "Expected color but found '-moz-initial'.  Error in parsing value for 'color'.  Declaration dropped." {file: "app://email.gaiamobile.org/style/mail.css" line: 2556 column: 9 source: "  color: -moz-initial;"}]
I/Gonk    (  108): Setting nice for pid 346 to 18
I/Gonk    (  108): Changed nice for pid 346 from 1 to 18.
D/memalloc(  108): /dev/pmem: Freeing buffer base:0x48d60000 size:614400 offset:4587520 fd:131
D/memalloc(  108): /dev/pmem: Freeing buffer base:0x48df6000 size:614400 offset:5201920 fd:135
D/memalloc(  346): /dev/pmem: Unmapping buffer base:0x44b00000 size:5201920 offset:4587520
D/memalloc(  346): /dev/pmem: Unmapping buffer base:0x45016000 size:5816320 offset:5201920
D/memalloc(  108): /dev/pmem: Freeing buffer base:0x48f22000 size:614400 offset:6430720 fd:123
D/memalloc(  108): /dev/pmem: Freeing buffer base:0x48e8c000 size:614400 offset:5816320 fd:115
I/Gonk    (  108): Setting nice for pid 457 to 18
I/Gonk    (  108): Changed nice for pid 457 from 0 to 18.
E/Profiler(  457): BEGIN mozilla_sampler_init
E/Profiler(  457): BPUnw: [1 total] thread_register_for_profiling(me=0x400e74f8, stacktop=0xbee80957)
E/Profiler(  457): SPS:
E/Profiler(  457): SPS: Unwind mode       = pseudo
E/Profiler(  457): SPS: Sampling interval = 0 ms (zero means "platform default")
E/Profiler(  457): SPS: Entry store size  = 0 (zero means "platform default")
E/Profiler(  457): SPS: UnwindStackScan   = 0 (max dubious frames per unwind).
E/Profiler(  457): SPS: Use env var MOZ_PROFILER_MODE=help for further information.
E/Profiler(  457): SPS:
E/Profiler(  457): Registering start signal
E/GeckoConsole(  457): Could not read chrome manifest 'file:///system/b2g/chrome.manifest'.
I/Gecko   (  457): ###################################### forms.js loaded
I/Gecko   (  457): ############################### browserElementPanning.js loaded
I/Gecko   (  457): ######################## BrowserElementChildPreload.js loaded
Note - we aren't seeing this on production builds, but we are seeing a failure to add accounts per bug 919587.
blocking-b2g: koi? → 1.3?

Updated

4 years ago
Blocks: 915223
I'm seeing this on 1.2 as well as master build still, with the patch.

I've tried rebuilding from scratch several times and it's not fixing it.  On a related issue, no timezones are listed when selecting timezones for the phone.  GMT is selected and the button to select timezones during initial setup pulls up an empty list.  I don't know if that's related to this issue or not, but I thought I'd mention it.

Also, the same behaviour is happening on builds by nearby people.  This is completely blocking me from replicating bug 915223, and I'm not sure what to do to get it resolved.
Asked around and played with some other devices, and it there's another Alcatel device that _doesn't_ show the issue.  In the process of obtaining an inari to test out whether problems exist or not.
Blocks: 886164
Have you tried this since https://bugzilla.mozilla.org/show_bug.cgi?id=886164 was backed out of MC?
(In reply to James Lal [:lightsofapollo] from comment #13)
> Have you tried this since
> https://bugzilla.mozilla.org/show_bug.cgi?id=886164 was backed out of MC?

Latest master build fixes this for me, testing on an inari.  Does anyone want this left open?  If not I'll close it as fixed.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.