Closed Bug 919023 Opened 7 years ago Closed 7 years ago

[B2G][Contacts][Facebook Import]Importing facebook friends to contacts page has improper graphical lines

Categories

(Core :: Graphics, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED WORKSFORME
blocking-b2g koi+

People

(Reporter: gbennett, Assigned: bjacob)

References

Details

(Keywords: regression, Whiteboard: burirun1)

Attachments

(2 files)

Attached image 2013-09-20-10-57-35.png
Description:
The facebook contact import page has vertical white lines in the top left corner partially covering the 'X' and 'F' in Facebook.

Repro Steps:
1) Updated Buri 1.3 mozRIL to Build ID: 20130916040205
2) Open contacts app
3) Press Settings button (gear)
4) Press sync friends and sign in
5) Import friends

Actual:
Facebook Friends import page has graphical glitch.

Expected:
No graphical glitch can be seen and the page works properly.

Environmental Variables
Device: Buri 1.3 mozRIL
Build ID: 20130920040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/59beb1868522
Gaia: 78a3e2509b979bd226f01f557bdf229fd3faa42e
Platform Version: 27.0a1

Notes: Does not repro on 1.1
Repro frequency: 100%, 2/2
See attached: 2013-09-20-10-57-35.png
Blocks: GFXB2G1.2
blocking-b2g: --- → koi?
Component: Gaia::Contacts → Graphics
Product: Boot2Gecko → Core
Version: unspecified → Trunk
QA Contact: nkot
Regression range:
Build ID: 20130919040201 - Does NOT Reproduce
Gecko: http://hg.mozilla.org/mozilla-central/rev/803189f35921
Gaia: 0dedb5b3789afc638a0c7c67652937fcb30e77d2
Platform Version: 27.0a1

Build ID: 20130920040201 - Reproduces
Gecko: http://hg.mozilla.org/mozilla-central/rev/59beb1868522
Gaia: 78a3e2509b979bd226f01f557bdf229fd3faa42e
Platform Version: 27.0a1
TO be koi, it needs to be on 1.2/aurora as well - does it happen there as well?

In the meantime, Matt, could you take a look at this, as switching to Azure on B2G in bug 914984 matches the regression range.
Flags: needinfo?(matt.woodrow)
(In reply to Milan Sreckovic [:milan] from comment #2)
> TO be koi, it needs to be on 1.2/aurora as well - does it happen there as
> well?
> 
> In the meantime, Matt, could you take a look at this, as switching to Azure
> on B2G in bug 914984 matches the regression range.

Right. Can someone check to see if this reproduces on 1.2?

If it does, then it's koi+. If it doesn't, then it's 1.3+.
Keywords: qawanted
Duplicate of this bug: 919593
does not reproduce on v1.2, so 1.3+

Build ID: 20130922004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2
blocking-b2g: koi? → 1.3?
Keywords: qawanted
Whiteboard: burirun1
I can reproduce this on a desktop b2g build that doesn't have azure enabled. Seems unlikely that my change would have caused it.
Flags: needinfo?(matt.woodrow)
Attached file logcat of issue
this issue has progressed to a contacts app blocker for smoketest.

When editing Contacts screen flickers then turns off and user must exit app with homescreen or long tap power button to recover.

Gaia   1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
SourceStamp 7eebf2d65429
BuildID 20130927004015
Version 26.0a2
Keywords: smoketest
(In reply to Allen Maxwell from comment #7)
> Created attachment 811194 [details]
> logcat of issue
> 
> this issue has progressed to a contacts app blocker for smoketest.
> 
> When editing Contacts screen flickers then turns off and user must exit app
> with homescreen or long tap power button to recover.
> 
> Gaia   1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
> SourceStamp 7eebf2d65429
> BuildID 20130927004015
> Version 26.0a2

That's a different bug than this. This bug is talking about graphical lines, not flickering. Open a new bug on this.
Keywords: smoketest
Duplicate of this bug: 923711
Jeni - The dupe you filed indicates this reproduces on 1.2. Can you double check this? The above testing indicates this does not reproduce on 1.2.
Flags: needinfo?(jcouassi)
(In reply to Jason Smith [:jsmith] from comment #10)
> Jeni - The dupe you filed indicates this reproduces on 1.2. Can you double
> check this? The above testing indicates this does not reproduce on 1.2.

Jason, Yes issue does repro on 

Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131004004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/a4b7282df517
Gaia: 9e21b6bea92fdafcb6787120a8cde0eb25a50495
Platform Version: 26.0a2
Firmware Version: 20130912
Flags: needinfo?(jcouassi)
blocking-b2g: 1.3? → koi?
the issue appeared in 1.2 just recently in 10/02 build, I've tested 9/22, 9/25, 9/28, 10/01 - no repros

-Last Working-
Gaia   5e0d0df6a762cf1e1812eeb735fba72e2539dc0c
SourceStamp 5689e4237ab7
BuildID 20131001004003
Version 26.0a2

-First Broken-
Gaia   def8e152db6a317162c03a316f68c409f3af3979
SourceStamp b955a00f4167
BuildID 20131002004001
Version 26.0a2
Sounds like then the regressing patch on central was uplifted to Aurora.
blocking-b2g: koi? → koi+
Recent regression, see comment 12.
Assignee: nobody → bjacob
needinfo on :bjacob here on what the next steps are here for this koi+ blocker.
Flags: needinfo?(bjacob)
I don't know if it's a good idea that I'm assigned on this bug, as I've had other koi+ bugs to work on, and this doesn't look like an area where I've worked before.

The regression window given in comment 12 gives this:

http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=5689e4237ab7&tochange=b955a00f4167

If we omit Gaia pushes, there are only very few mozilla-central changesets in this window:

	ee2954428768	Steven Lee — Bug 918056 - Return errors when the mic is occupied. r=rjesup, a=koi+
	e6472281dabf	Sotaro Ikeda — Bug 914870 - Reduce mp3 parse chunk buffer size to 32KiB. r=doublec, a=koi+
	2c8195814437	Gina Yeh — Bug 913374 - Use nsRefPtr for BluetoothProfileController in profile managers. r=echou, a=koi+
	acdf04eaaceb	Szu-Yu Chen [:aknow] — Bug 897940 - Extend timeout. r=hsinyi, a=test-only
	844587e80414	Kartikaya Gupta — Bug 916379 - Remove a content repaint request that was clobbering the right frame metrics with the wrong one. r=BenWa, a=koi+
	eb1b2309837f	Fabrice Desré — Bug 914854 - BrowserElementPanning causes sync reflow by quering scrollLeft/Top. r=bz, r=vingtetun, a=koi+
	772abe4f65ec	Fernando Jiménez — Bug 919429 - [Message manager] We must not force weak listeners to implement Ci.nsIMessageListener. r=smaug, a=koi+



Of these, only these two changesets look like they might conceivably be related to graphical glitches:


	844587e80414	Kartikaya Gupta — Bug 916379 - Remove a content repaint request that was clobbering the right frame metrics with the wrong one. r=BenWa, a=koi+
	eb1b2309837f	Fabrice Desré — Bug 914854 - BrowserElementPanning causes sync reflow by quering scrollLeft/Top. r=bz, r=vingtetun, a=koi+


I suggest asking :kats and :fabrice about that! Needinfo'ing them.
Flags: needinfo?(fabrice)
Flags: needinfo?(bugmail.mozilla)
Flags: needinfo?(bjacob)
Pretty sure this is unrelated to my change in bug 916379; that affects the initial size of the page and shouldn't result in graphical glitches like the one in the screenshot.

Also, the regression range on central from comment 1 is this: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=803189f35921&tochange=59beb1868522

In theory the guilty change should be in both regression ranges but there are no gecko changes that are in both those ranges. It might be a gaia change.
Flags: needinfo?(bugmail.mozilla)
I can't repro on a leo running current 1.3. Can QA check if this is buri-only?
Flags: needinfo?(fabrice)
(In reply to Fabrice Desré [:fabrice] from comment #18)
> I can't repro on a leo running current 1.3. Can QA check if this is
> buri-only?

Added keyword.
Keywords: qawanted
Unable to reproduce this issue on both the Buri and Leo 1.3 Build ID: 20131101040203

Gaia   ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
SourceStamp abe6790a5dd8
BuildID 20131101040203
Version 28.0a1
Keywords: qawanted
What about 1.2?
Keywords: qawanted
This issue does not reproduce on Buri 1.2 Build ID: 20131101004000

Gaia   e717aec947571f5daf923c040a82f9f0719bb526
SourceStamp 54de309e18a9
BuildID 20131101004000
Version 26.0
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.