[B2G][MMS][Notification] No error message in the notification when the data is disconnected while receiving MMS

RESOLVED INVALID

Status

()

Core
DOM: Device Interfaces
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1)

(Reporter)

Description

5 years ago
Description:
No any notification when disabling data connection while receiving MMS

PREREQUISITES: * Automatic retrieval of MMS turned on

Repro Steps:
1) Updated Buri to Build ID: 20130916040205
2) Open "Settings" app from the home screen
3) Navigate to "Cellular & Data"
4) Navigate to "Message Settings"
5) Make sure that "Auto retrieve" option is "ON"
6) Scroll down to "MMS port" and change the port to "80" (without quotes)
7) Send MMS file from another device
8) Disconnect data on the testing device

Actual:
No any error notification that MMS cannot be downloaded because of loosing connection

Expected:
The error message appears in the notification bar notifying the user that connection is lost 

Environmental Variables
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
Test Suite Name: MMS
Link to failed test case:
https://moztrap.mozilla.org/manage/cases/?filter-id=8266
Gene, do you think this is fixed by bug 901992 ?
Flags: needinfo?(gene.lian)
Mmm Bug 901992 landed a long time ago so probably not.
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
Likely not a regression for 1.1, but can you double check?
Flags: needinfo?(sarsenyev)
Keywords: qawanted
Looping Ken/Ctai/Steve who used to work on the interaction between data connection and MMS.

As far as I know, from the point of view of Gecko, we don't need to turn on data connection to send/receive MMS, which means we don't need to pop up an error notification when the device is data-disconnected.

This bug sounds invalid to me.
Flags: needinfo?(gene.lian)
Fair enough.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(sarsenyev)
Keywords: qawanted
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.