Scrolling up slowly above Java app draws bad content

RESOLVED DUPLICATE of bug 90814

Status

Core Graveyard
GFX
--
minor
RESOLVED DUPLICATE of bug 90814
17 years ago
9 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Peter Lubczynski)

Tracking

Trunk
mozilla1.2alpha
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build: 2001072008, Mac OS 9.1

To reproduce:
1.  Go to <http://exodus.mit.edu/~jesse/java/percep/>.
2.  Scroll down so that the only thing visible in the Navigator window is the
    Java applet.
3.  Drag the scrollbar thumb back up to the top, moderately slowly. (Too slow or
    too fast, and this bug won't occur.)

What should happen:
*   The top of the page appears as expected, yada yada.

What actually happens:
*   A stripe of the ~60 leftmost pixels does not scroll properly -- it appears
    that when the currently drawn area is copied from the top of the content
    area to be pasted further down, it's not quite the correct area which is
    being copied.
*   It would be a convenient clue if the right edge of the area which doesn't
    scroll properly was the same as the left edge of the applet, but this ain't
    so.

I don't think this is the same as bug 86695 (which I've also seen on occasion),
because that bug applies to a whole horizontal line along the content area,
whereas this bug only applies to a small part of the line.
(Reporter)

Comment 1

17 years ago
Created attachment 43211 [details]
Screenshot of the problem

Comment 2

17 years ago
You are right, it's not a dupe
However, i cant reproduce this. When i just scroll down or up, i see a little
gray line in the java applet, but it cleans itself after scrolling, it lasts
only while you are scrolling, and it does not annoy me enough to call it a "bug"

Anyway thanks for pointing bug 86695 , i was looking for that catfood long time ago
Peter I, think this is a dup of one of your bugs.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2
(Assignee)

Comment 4

16 years ago
yes, I think it is a dup of a plugin/scrolling bug.....taking for now
Assignee: kmcclusk → peterlubczynski
Status: ASSIGNED → NEW

Comment 5

16 years ago
marking as a dup of 90814, even though that points to QT, it is really more
generic than that

*** This bug has been marked as a duplicate of 90814 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.