Thunderbird doesn't check for new e-mails on start-up if feed account appears before POP e-mail account

RESOLVED DUPLICATE of bug 881114

Status

RESOLVED DUPLICATE of bug 881114
5 years ago
5 years ago

People

(Reporter: klasse, Unassigned)

Tracking

24 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I don't remember exactly how (possibly due to deletion and re-creation of the e-mail account earlier), but in the left hand side pane I used to have following account order (top to bottom):
- Blogs & News Feeds
- a POP e-mail account
- Local Folders

In that configuration, despite correct settings, Thunderbird did not check for new e-mails on start-up. (And no connection attempt was shown in the status bar on start-up.) So that, to check for new e-mails, one needed to manually click on the "Get Mail" button, which worked without problems.

To work around the issue, the "Blogs & News Feeds" account was deleted and re-added. After which it appears as last in the left hand side pane (first now comes the e-mail and then the Local Folders) and e-mails are now correctly checked on start-up.

No other configuration was modified between the time when the problem existed and deletion and re-creation of the feed account which instantly solved the problem.


The problem was not new in version 24, but had persisted for a long time before. (I'm not sure how long, maybe a year or longer.) And it seems that other people have experienced a similar problem before - see e.g. following, which gave me the idea for the workaround: http://forums.opensuse.org/english/get-technical-help-here/applications/474842-thunderbird-12-doesnt-check-mail-startup.html#post2458983
Problem you saw is bug 881114 which is still open.
"defaultaccount==non POP3/non IMAP account==RSS account" was perhaps produced by bug 880464 in your case.

> To work around the issue, the "Blogs & News Feeds" account was deleted and re-added.

It is simply that bug 880464 is fixed in Tb 24.
Becaue bug 880464 is fixed in Tb 24, RSS account was not set as defaultaccount by RSS account definition by Tb 24.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881114
You need to log in before you can comment on or make changes to this bug.