onMouseOver doesn't fire if div positioned outside parent

VERIFIED DUPLICATE of bug 13213

Status

()

VERIFIED DUPLICATE of bug 13213
18 years ago
17 years ago

People

(Reporter: mike, Assigned: joki)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)
BuildID:    2001072303

at http://reversal.org/tests/testing.html, moving the mouse over either of the 
red boxes ought fire a mouseover event, and change their background colour to 
blue.  

the first box is positioned completely outside it's parent div, and the 
mouseover event simply doesn't happen.  the second box is half in/half out of 
the parent div, and the mouseover event fires only when the mouse is over the 
portion of the div fully contained within the parent div.

Reproducible: Always
Steps to Reproduce:
1. go to http://reversal.org/tests/testing.html
2. mouseover a portion of either red div that is outside the blue div


Actual Results:  nothing

Expected Results:  red div should have fired a mouseover event, and changed 
it's background colour to blue.  the mouseover event should then bubble up to 
the blue div, and change it's background colour to red.
I've seen this filed before, but I can't find it...
Whiteboard: DUPEME

Comment 2

18 years ago
CONFIRMING on Win2k 20010829
Had a good look and couldn't find a DUPE either.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
WFM, 2001092503, WindowsME

*** This bug has been marked as a duplicate of 13213 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
I had already noted this in #97000, which was also marked as duplicate of #13213, a more than TWO YEARS OLD MAJOR FLAW...But there were no reaction.Is there anyone working on this ?Or should we definetly stop using CSS with Mozilla ??

Comment 6

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.