Other applications which can handle URL intent ignored

RESOLVED DUPLICATE of bug 899376

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 899376
5 years ago
2 years ago

People

(Reporter: Alistair Cunningham, Unassigned)

Tracking

24 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911155657

Steps to reproduce:

I tapped on a link to reddit.com on a page displayed in Firefox for Android 24.


Actual results:

The link loaded in Firefox.


Expected results:

The link should have loaded in the "reddit is fun golden platinum" application, which has a superior native Android interface for browsing reddit.com, and which handles Android Intents for reddit.com.

The same happens with tripadvisor.com and the TripAdvisor application.

It seems that Firefox for Android ignores other applications which specifically handle URL Intents.
(Reporter)

Updated

5 years ago
OS: Linux → Android
Hardware: x86 → ARM
We offer this capability in Firefox 26 on Aurora and Firefox 27 on Nightly; see bug 899376.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 899376
(Reporter)

Comment 2

5 years ago
Thanks!
Alistair, see also bug 851693, which I think covers the request you are describing.
You need to log in before you can comment on or make changes to this bug.