Closed Bug 919469 Opened 9 years ago Closed 9 years ago

After rebooting the phone, singleVariant are reinstalled

Categories

(Core Graveyard :: DOM: Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox26 fixed, firefox27 fixed, b2g-v1.2 fixed)

RESOLVED FIXED
mozilla27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed
b2g-v1.2 --- fixed

People

(Reporter: macajc, Assigned: macajc)

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

No description provided.
Sorry about the empty c0, I hit submit by error.

STR: 
1. Create a build with single variant operator apps
2. Boot the phone a first time
3. Operator apps are installed
4. Shutdown the phone (either normally or removing the battery)
5. Reboot the phone

Expected:
Operator apps are not installed again

Actual: 
Operator apps are installed again. The user isn't really impacted (since 'installed again' just means the installation is launched but doesn't succeed since the apps were installed previously).

The root cause is the default value for the preference is incorrect. It's false and it should be true. Also, the preference file should be saved after modifying it so if the phone is shut down incorrectly (removing the battery) the change isn't lost.
Summary: After rebooting the phone, singleVariant → After rebooting the phone, singleVariant are reinstalled
[Approval Request Comment]
Bug caused by (feature/regressing bug #): Operator Single Variant Apps
User impact if declined: The system will try to install the operator apps every time the phone is booted. The user will be notified of this.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Very low, it's just modifying the default value of a pref and ensuring the prefs are saved when the system is shut down incorrectly. 
String or IDL/UUID changes made by this patch: None
Attachment #808524 - Flags: review?(fabrice)
Attachment #808524 - Flags: approval-mozilla-aurora?
Whiteboard: [systemsfe]
Attachment #808524 - Flags: review?(fabrice) → review+
The try run finished only with one problem that is already reported and it's not related with this, so requesting checkin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6a5112cc49e7
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Attachment #808524 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: rafael.marquez
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.