[Browser] Searching for words in the URL bar is not giving a search results

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Browser
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: zac, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox27 affected, b2g-v1.2 unaffected)

Details

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #905831 +++

## Environment :
"gecko" revision="a8daa428ccbc"
"gecko" revision="f7df54d21e1b4fed66083d80b701c3692e1cffd4"
"gaia" revision="58bb05efc83407428099a182244a1759ab84cd0b"
Build ID: 2013-08-15-04-02-04
MC/master build
Unagi

Prereq: no SIM card

STR:
1. launch browser
2. tap in the URL bar
3. type "Yomiuri"
4. tap the magnifying glass icon

Expected: A search from the default search engine with results of "yomiuri"
Actual: www.yomiuri.com in URL bar / Server not found error in content

Note:
1. also tried "test blah" return result was http://test blah

+++


This has regressed again. Identical STR/symptoms.

Build:
http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2013-09-23-04-02-14-mozilla-central/

(Couldn't test on device just yet, apologies)
(Reporter)

Updated

5 years ago
No longer blocks: 840210
(Reporter)

Comment 1

5 years ago
Now validated on device.

Device Hamachi
Gecko  http://hg.mozilla.org/mozilla-central/rev/f97307cb4c95
Gaia  3408cc3f6b190c8cd31832fbb8cd2ae571041f29
BuildID 20130923040214
Version 27.0a1
I can reproduce the issue on the desktop build

Updated

5 years ago
blocking-b2g: koi+ → koi?
Keywords: regression, regressionwindow-wanted
In the future, avoid cloning bugs. It causes flags to be set that shouldn't be set on initial file of the bug.

Updated

5 years ago
QA Contact: dwatson

Comment 5

5 years ago
The issue is not reproducible on 1.2, typing words in the URL bar and clicking the Search icon will display a google search for the word.
Buri Build ID: 20130922004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2


The window for the issue appears to be between 09/20 and 09/21.

Does not occur-
Buri Build ID: 20130920040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/59beb1868522
Gaia: 78a3e2509b979bd226f01f557bdf229fd3faa42e
Platform Version: 27.0a1

Occurs on-
Buri Build ID: 20130921040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/a2c31dc69ab3
Gaia: 37866768b8abda56d089c8fe96ec5298fc1df696
Platform Version: 27.0a1

Changed blocking flag to 1.3? instead of Koi? since it appears to be a 1.3 issue.
blocking-b2g: koi? → 1.3?
status-b2g-v1.2: --- → unaffected
status-firefox27: --- → affected
Keywords: regressionwindow-wanted
I think it may be a repeat of bug 905831 on moz central.  The search engine in the settings is blank.  I need to dig further on this to make sure, it looks like it might be a config issue...
The init.json is populated for the browser after pulling the application.zip file from the browser app.

Updated

5 years ago
Blocks: 884399

Updated

5 years ago
No longer blocks: 884399
Naoki - Can you dig into this to find out if this is configuration issue in our flashing or a browser bug?
Flags: needinfo?(nhirata.bugzilla)
Please see comment 7.  The init.json is populated. So it's a browser bug.
Question is does this still occur?  This is an old bug.
Flags: needinfo?(nhirata.bugzilla)
QA Wanted for comment 9
Keywords: qawanted
(Reporter)

Comment 11

5 years ago
This doesn't occur anymore and automation covers it against regression.
Closing as works for me per comment 11 then.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.