Closed Bug 919555 Opened 8 years ago Closed 8 years ago

[e.me][perf] Remove app index duplicacy

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ranbena, Assigned: amirn)

References

Details

(Keywords: perf, Whiteboard: [c=memory p= s=2013.11.08 u=])

Attachments

(1 file, 1 obsolete file)

Evme indexes Grid Apps which takes over 600k. This should be avoided.
Assignee: nobody → ran
Blocks: 914875
Status: NEW → ASSIGNED
Attached file Patch - redirect to github PR.html (obsolete) —
This patch necessary code changes from Bug 911568
Attachment #809980 - Flags: review?(crdlc)
Attachment #809980 - Flags: feedback?
Attachment #809980 - Flags: feedback?
This PR takes off over 400k because it removes the need for 2 installed app indexes.

In order to test the feature, simply search for the following:
* Category - apps in this category will appear ("utilities", "music", "social")
* Apps begining with the query (type "m" and marketplace, music, etc. will appear)
Duplicate of this bug: 911568
Keywords: perf
Whiteboard: [c= p= s= u=][perf-reviewed]
blocking-b2g: --- → koi+
Whiteboard: [c= p= s= u=][perf-reviewed] → [c= p= s= u=1.2]
No longer blocks: 1.3-e.me
I removed this as a blocker as it's not a huge benefit and Bug 921100 should have brought in a substantial mem save  (because of Bug 916060).
Priority: -- → P1
Ran - Is this part of the 1.2 e.me changes or is this separate? Trying to figure out if this needs to remain as a koi+ or not.
Flags: needinfo?(ran)
No it shouldn't. Please change to koi-.
Flags: needinfo?(ran)
blocking-b2g: koi+ → ---
Whiteboard: [c= p= s= u=1.2] → [c= p= s= u=]
Assignee: ran → amirn
Depends on: 929437
Attachment #809980 - Attachment is obsolete: true
Attachment #809980 - Flags: review?(crdlc)
Attachment #823994 - Flags: review?(ran)
Attachment #823994 - Flags: review?(crdlc)
Amir, can you rebase the commit?
Flags: needinfo?(amirn)
done
Flags: needinfo?(amirn)
Comment on attachment 823994 [details]
redirect to PR 13181.html

The homescreen code looks good to me! r+
Attachment #823994 - Flags: review?(crdlc) → review+
updated PR,

Cristian - changes in page.js and grid.js as we discussed
Ran - ready for your r+ now :)

Thanks
Comment on attachment 823994 [details]
redirect to PR 13181.html

Kudos! 500k memory consumption reduction!
Attachment #823994 - Flags: review?(ran) → review+
Whiteboard: [c= p= s= u=] → [c=memory p= s= u=]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [c=memory p= s= u=] → [c=memory p= s=2013.11.08 u=]
blocking-b2g: --- → 1.3?
Clearing nom - this is already part of 1.3, so this doesn't need to be triaged.
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.