Make supersearch understand "normal" values for hang type and process type

RESOLVED FIXED in 76

Status

P1
normal
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: adrian, Assigned: adrian)

Tracking

unspecified

Details

(Whiteboard: [qa+])

(Assignee)

Description

5 years ago
The values stocked in the database are not "hang", "crash", or "plugin" (for example) but integers. We should make the middleware able to understand those values, and then re-activate the corresponding options in the UI.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 966026
(Assignee)

Comment 2

5 years ago
Pull request: https://github.com/mozilla/socorro/pull/1857

Steps to QA
-----------

1. Go to Super Search.
2. Verify that "Hang type" and "Process type" are in the list of available parameters.
2. Run searches with various values for "hang type" and "process type", verify they return results and no error happens.
(Assignee)

Updated

5 years ago
Whiteboard: [qa+]
(Assignee)

Updated

5 years ago
Target Milestone: --- → 73

Comment 3

5 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/c74678903cefb152480fa5c18512ee5de1f1547b
Fixes bug 919559 - Added process_type and hang_type to Super Search. r=peterbe
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Target Milestone: 73 → 76
Product: Socorro → Socorro Graveyard
You need to log in before you can comment on or make changes to this bug.