"Delete folder" menu item should be available for trash folder after users switch delete mode to "Mark as Deleted" & "Remove Immediately" modes

RESOLVED FIXED in seamonkey2.8

Status

RESOLVED FIXED
18 years ago
7 years ago

People

(Reporter: huang, Assigned: mkmelin)

Tracking

Trunk
seamonkey2.8

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Used 07-23-06-0.9.2 build

"Delete folder" menu item should be available for trash folder after users 
switch delete mode to "Mark as Deleted" & "Remove Immediately" modes

This bug is tracking the follow-up problem after fix from bug 39121.

Steps: 
1) Used the account with the "Mark as Deleted" & "Remove Immediately" modes
2) Select the Trash folder
3) Select "Delete folder" menu item from the menu bar
4) Actual Results: "Delete folder" menu item is greyout (disable)for trash 
folder of "Mark as Deleted" & "Remove Immediately" modes.

Expected results: "Delete folder" menu item should be available for trash folder 
after users switch to "Mark as Deleted" & "Remove Immediately" modes since trash  
should fall into the alphabetical regular folder (see bug 39121)


Additional Info:

1) bug 39121 is for "Unspecialize Trash folder when change IMAP delete mode to 
"Mark as Deleted" & "Remove Immediately" modes.After fix bug 39121, the Trash 
folder will fall into the alphabetical regular folder hierarchy , so "delete 
folder" menu should be available for delete this trash folder. 
(adding bug 39121 for this bug's dependance)

2) There was bug 33235 logged for "Shouldn't allow deleting special folders when 
Account Setting setup special folders on server", logging this bug is for 
tracking other exceptions.
(Reporter)

Updated

18 years ago
Depends on: 39121
QA Contact: esther → huang
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: huang → message-display
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → EXPIRED
Bulk reopening incorrectly expired bugs - no activity does not constitute no bug - these need proper checking.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---
Status: REOPENED → UNCONFIRMED
Confirming in the light of bug 39121 still being open, and that one being a dependency of this one. If bug 39121 is closed, this one needs to be closed, too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: x86 → All
(Assignee)

Comment 4

7 years ago
Bug 39121 fixed this for seamonkey too.
Assignee: nobody → mkmelin+mozilla
Status: NEW → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.8
You need to log in before you can comment on or make changes to this bug.