[B2G] [Buri] [Calendar] App crashes when loading an account with a large amount of calendar events

RESOLVED DUPLICATE of bug 917594

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 917594
4 years ago
4 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

({regression})

Trunk
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 808729 [details]
Log of calendar crash

Description:
The calendar app is prone to crashing when the user attempts to sync an account with a large amount of calendar events.

Repro Steps:
1) Update Buri to Build ID: 20130922004001
2) Launch the calendar app.
3) Login with an account with a lot of calendar entries (eg one with a daily calendar event).
4) Observe the device as the events load.

Actual:
The calendar app crashes.

Expected:
The events are loaded into the Calendar app with no errors.

Environmental Variables
Occurs on Buri 1.2 mozilla RIL
Build ID: 20130922004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2

Notes:
Repro frequency: 90%
Test Suite Name: Calendar
UCID: calendar-045
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=3853
See attached logcat logs
(Reporter)

Comment 1

4 years ago
Crash report URL: https://crash-stats.mozilla.com/report/index/5a790bc8-8b6d-4069-8c91-0480e2130923
Some questions:

1. Is this consistently reproducible?
2. Is it possible to get a regression window?

Let's start with question #1 - see if someone else can reproduce this multiple times or not.
blocking-b2g: --- → koi?
Component: Gaia::Calendar → JavaScript Engine
Product: Boot2Gecko → Core
Version: unspecified → Trunk

Updated

4 years ago
Keywords: qawanted

Updated

4 years ago
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 917594
You need to log in before you can comment on or make changes to this bug.