Closed Bug 919714 Opened 6 years ago Closed 6 years ago

[B2G][SMS] After closing SMS using task manager, parts of the edit contact page will disappear when scrolling the page

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 918671
blocking-b2g koi+
Tracking Status
b2g18 --- unaffected
b2g-v1.2 --- affected

People

(Reporter: KTucker, Unassigned)

References

Details

(Keywords: regression, Whiteboard: burirun1)

Attachments

(2 files)

Description:
If a user long presses on a number or email in a SMS to add to an existing contact, kills the SMS app while on the "Edit Contact" page and then goes back to add new information to a new contact again from a SMS, parts of the "Edit Contact" page will disappear when scrolling the page.

Repro Steps:
1)  Updated to Buri Build ID: 20130922004001
2)  From a different phone, send a SMS to the test phone that contains a phone number.
3) On the test phone, tap the "SMS" icon to open messaging.
4) View the SMS sent from the other phone and long press on the phone number in the message.
5) Select "Add to an existing contact".
6) Select a contact to add the phone number to.
7) While on the "Edit Contact" page, hold down the "Home" button on the phone to open task manager and kill the SMS application.
8) Tap on the "SMS" icon again to relaunch the application.
9) Open the SMS that contains the phone number.
10) Long press on the phone number and select "Add to an existing contact".
11) Select a contact again and immediately scroll the page when the "Edit Contact" page appears.

Actual:
Parts of the "Edit Contact" page will disappear and sometimes the header becomes distorted when scrolling the page.

Expected:
The "Edit Contact" page scrolls smoothly without issue.

Environmental Variables
Buri Build ID: 20130922004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2

Notes:
Repro frequency: (100%)
See attached: (screenshot and logcat)
Attached image Screenshot
Summary: [B2G][SMS] Closing SMS using task manager while on the edit contact page causes parts of the edit contact page to disappear when the user tries to add new information to a contact from a SMS → [B2G][SMS] Closing SMS using task manager causes parts of the edit contact page to disappear when the user tries to add new info to a contact from a SMS
Summary: [B2G][SMS] Closing SMS using task manager causes parts of the edit contact page to disappear when the user tries to add new info to a contact from a SMS → [B2G][SMS] Parts of the edit contact page will disappear or become distorted when scrolling
Summary: [B2G][SMS] Parts of the edit contact page will disappear or become distorted when scrolling → [B2G][SMS] After closing SMS using task manager, parts of the edit contact page will disappear when scrolling the page
I'd say it's more a Contacts issue.
Component: Gaia::SMS → Gaia::Contacts
A video would be helpful to include here.
blocking-b2g: --- → koi?
QA Contact: sparsons
Video of issue: http://youtu.be/Yk220Z5fmLY

This issue started to reproduce on the 9/20 Buri 1.2 Aurora Build ID: 20130922004001

Environmental Variables
Build ID: 20130922004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2
RIL Version: 01.01.00.019.197 

Last working build 9/19 Buri 1.2 Aurora Build ID: 20130919004001

Environmental Variables
Build ID: 20130919004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/2e560c5ce351
Gaia: c932c482c6944fa32724ce7af9e5423c4c2bcccd
Platform Version: 26.0a2
RIL Version: 01.01.00.019.197
Looks like a graphics bug.
Blocks: GFXB2G1.2
Component: Gaia::Contacts → Graphics: Layers
Product: Boot2Gecko → Core
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918671
Duplicate of a koi+
blocking-b2g: koi? → koi+
Duplicate of this bug: 919593
You need to log in before you can comment on or make changes to this bug.