xml parse error on startup.

VERIFIED WORKSFORME

Status

SeaMonkey
Startup & Profiles
--
major
VERIFIED WORKSFORME
17 years ago
12 years ago

People

(Reporter: duane ellis, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
This is *NOT* a NETSCAPE bug, this is a MOZILLA bug, I'm using
NETSCAPE 4.72 to submit this bug because I cannot get MOZILLA
to even start on my Win98 box. (I specifically say this because
the non-editable field listed below says "some fields initialized from your 
user-agent Moziilla/4.72 [en] (win98 U)

mozilla-win32-0.9.2-installer.exe (downloaded jul 20, 2001)
I can't get the thing started to get a "BUILD-ID" otherwise
I would give you the build id.

Installation seemed OK, but mozilla will not start. It has *NEVER*
started on this Win98 BOX, not even to the "fire breathing dragon"
splash screen.

PROBLEM 1 & 3) 

ON startup of the browswer I get:
(identical error when starting "profile manager")

xml paring error: undefined entity
Locatoin: chrome://navigator/content/navigator.xul
line number 189, column 94:

crop="right" buttonaction="BrowserPrint()" tooltip="aTooltip" 
tooltiptext="&printButton.tooltip;">

There is a ---^ sequence, the ^ is pointing at 'i' in the last occurance
of the word ".tooltip;".

Problem #2 (related)
starting MAIL I get same type of error, but this time
location: chrome://messenger/content/messenger.xul
line: 128, column 24:

<menuitem label="&CopyEmailAddress.label;"
-----------------------^ (caret under "m" in email

---------------------

I'm a developer, I know my description sucks, but... I am stopped
dead cold, can't even get the "splash" screen to come up.

Same build (I think) works fine at work on Win2K machine

Downloaded Linux version later in the evening (7-20-01) and it does
not have this problem.

I think it might have to do with how my WinBloze box is configured
but I can't find, nor figure out what to look for. If you could tell
me what to look for - I'll look.
How did you install on the Windows box?  Overwriting the old install?  Clean
install into a new directory?
(Reporter)

Comment 2

17 years ago
Install clean to a new directory. 

Note that I have Netscape 6 installed (But do not use it) 
I had installed 6 a long time ago - but did not like it and 
went back to netscape 4.7x 

I install mozilla to "program files/mozilla.org" (the default) 
I never had that directory before. 

When install was complete, it seemed to find my old profile 
(just like it did at work, on win2K where it works) 
I'm not sure which profile it found, 4.7x or 6. 

Is there anything I can look for/at? 
Try creating a new profile?  It's possible that the NS 6 profile is screwing
this up....
(Reporter)

Comment 4

17 years ago
boris> Try creating a new profile?  It's possible that the NS 6 profile 
       is screwing this up....

It's kind of a "catch-22" situation.

How would i create a new profile if I can't even get mozilla
to start so I can get a screen to create a new profile?
hmm.  You get the same error starting profile manager?

Then it's not a profile issue...

setting status to NEW and ccing the installer component owner for thoughts.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Try with this command line option: -ProfileManager
(Reporter)

Comment 7

17 years ago
boris> hmm.  You get the same error starting profile manager?

Yes, but not exactly - same basic error - different files based on
what I start up, I can't get anything to start without an error message.

heikki> Try with this command line option: -ProfileManager

I've tried the "-ProfileManager" option no luck.

Is there a list of things that I can specify on the command line
to start this thing?

like a debug trace output or something?

I've tried the common I could think of - things, like "-help" 
and -? and other things. Nothing seems to work. I would have
expected something like: "usage: ..." but got nothing.

boris> setting status to NEW and ccing the installer component 
       owner for thoughts.

How do I do that?

I'm changing the 'severity to major' (I mis-understood what
the severity codes are) as I can use *NO* part of this program
in anyway shape or form. I count that as "major show stopper"
Severity: blocker → major
Component: XML → Installer
I agree that this most likely is NOT an XML bug. The parser is reporting that it
has found an entity it does not recognize, so I am assuming the installer or
packager or something has gone awry and a complete package has not been
installed. I am reassigning to owners of the Installer component.

Duane, could you please zip up your chrome directory and attach it to this bug?
(For Netscape 6 it will typically be "C:\Program Files\Netscape\Netscape
6\chrome", not sure what it would be for Mozilla). Once you do that we can try
to see what is missing.
Assignee: heikki → ssu
QA Contact: petersen → gemal

Comment 9

17 years ago
This is not a installer bug.
Please try the following:
1) Uninstall Mozilla through Control Panel. This will not harm your profiles.
2) Download a new installer: 
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer.exe
3) Install Mozilla
Assignee: ssu → asa
Component: Installer → Browser-General
QA Contact: gemal → doronr
(Reporter)

Comment 10

17 years ago
Created attachment 43610 [details]
install screen with no menu text (screen shot)
(Reporter)

Comment 11

17 years ago
Created attachment 43611 [details]
missing menu text from startup screen (screen shot)
(Reporter)

Comment 12

17 years ago
heikki> ... zip my chrome directory and attach.

I did, It fails to upload. I have no idea why, file size: 2.6meg
Would a list of "md5" sums be a good alternative? It's a smaller file?

Henrik Gemal> reinstall using latest download.

Did that, (note CHROME zip file I have is from *BEFORE* i reinstalled)

Web install downloads *FAST* previously I did the full installer and
it takes for ever to download via FTP.

New version works better - in that I get past the xml problem,but now
I have *NO* (zero, nada, zip, null, nothing) for menu text in 90% of
the menus. Absolutly weird, same is true of all programs (mail, profile
and browser) I made Screen shots showing what I mean (windows BMP files)

Those are small files - I can attach them.
(Reporter)

Comment 13

17 years ago
Created attachment 43615 [details]
md5sums of my chrome directory
Hmm, strange about the zip attachment not working. Could you email the zip to
me, at heikki@netscape.com, please? Good thinking about the md5sums, but I would
like to start with the actual chrome if possible...

Looking at the screenshots, Mozilla is definitely picking up either wrong
chrome, and/or wrong localizations and/or someone's customizations. Have you
modified your chrome, done localization work, or installed additional packages
that are supposed to work with Mozilla?
(Reporter)

Comment 15

17 years ago
heikki> Hmm, strange about the zip attachment not working. 

I think it's the size - 2.6meg.

heikki> Could you email the zip to me, at heikki@netscape.com, please? 
        Good thinking about the md5sums, but I would like to start with
        the actual chrome if possible...

No problem. I just mailed it to you from my @home account.

-Duane.



heikki> Looking at the screenshots, Mozilla is definitely picking up 
        either wrong chrome, and/or wrong localizations and/or 
        someone's customizations. Have you modified your chrome, 
        done localization work, or installed additional packages
        that are supposed to work with Mozilla?

No nothing, remove & reinstall. Nothing else, stock out of the box.

-Duane.
What I meant, have you EVER installed additional Mozilla packages/modifed
chrome/etc. on the affected computer? Some old stuff might be the cause of this.
Check that you do not have any Mozilla stuff in your Windows directory (like
mozregistry.dat or something).

The Manage Profiles screenshot shows the Start and Exit buttons have wrong
labels, "Start Yah" and "Exit Yah". That "Yah" might be the beginning of some
longer word, like Yahoo. I have been looking at the zip you sent me, and so far
I have not found anything unusual... 
(Reporter)

Comment 17

17 years ago
heikki> What I meant, have you EVER installed additional Mozilla 
       packages/modifed chrome/etc. 

No.

I am an advid Netscape user. I have been using Netscape 4.72
A while ago - when Netscape 6 came out, I tried it did not like it
and removed it, went back to 4.72. 

I am an 'average user' I have tried *ZERO* customizing
other then various widely popular plugins (Flash, Java, QuickTime)
nothing else.

I downloaded Mozilla, and installed it and these problems have occured.

heikki> heck that you do not have any Mozilla stuff in your 
        Windows directory (like mozregistry.dat or something).

I did not know MOzilla did anything like that, I would not have
known to look for this. How would I tell if a file is for Netscape 4.72
vrs Mozilla propper? 

Is there anything else I should look for?

-Duane.

Comment 18

16 years ago
->apps
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh

Comment 19

16 years ago
profilemanager people should know the possible points of failure...
Assignee: pchen → ben
Component: XP Apps → Profile Manager FrontEnd
QA Contact: sairuh → ktrina
WORKSFORME.. have never seen this.. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 21

16 years ago
Verified WFM. Reporter, please reopen if problem still occurs.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.