If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Tablet] The search view is stuck on top when performing youtube searches until the user triggers a repaint

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
4 years ago
a year ago

People

(Reporter: AdrianT, Assigned: botond)

Tracking

({regression})

Trunk
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25- wontfix, firefox26 unaffected, fennec25+)

Details

(URL)

(Reporter)

Description

4 years ago
Firefox Mobile 25 beta 2
Asus Transformer TF101(Android 4.0.4)/ Acer A500 (Android 3.0)

Steps to reproduce:
1) In landscape load youtube.com
2) Do a search for any string

Expected result:
The list of suggestions is displayed

Actual results:
The search start view with the "Loading" toast remains on top until the user triggers a repaint by rotating the device. Please see the video: http://youtu.be/qjKK9m4xc8s

Notes: This is not reproducible on Firefox Mobile 24 from Google Play or Aurora 26.0a2 2013-09-23
Finding a fixed window would be helpful.
Keywords: regression, regressionwindow-wanted
Whiteboard: regression

Comment 2

4 years ago
I was not able to reproduce this issue every time. When the view gets stuck the following error is displayed continuously in logcat: 
09-25 19:38:09.580: E/libEGL(11872): eglMakeCurrent:684 error 3009 (EGL_BAD_MATCH)
Botond - Since this is fixed in Fx26 but broken on Fx25, do you think your APZC frame scrolling fix might help here too?
Flags: needinfo?(botond)
(Assignee)

Comment 4

4 years ago
(In reply to Mark Finkle (:mfinkle) from comment #3)
> Botond - Since this is fixed in Fx26 but broken on Fx25, do you think your
> APZC frame scrolling fix might help here too?

I assume you mean bug 904533 and related patches. It's possible that they are what fixed this problem. Kats has a try job for those patches applied to beta (https://tbpl.mozilla.org/?tree=Try&rev=9299a59f7836), we can test them when they finish building.
Flags: needinfo?(botond)
So (a) I'm not able to reproduce the problem on a Nexus 4 running 25b6 so I can't see if the patches from bug 904533 fix it and (b) from the video it doesn't look like this is related at all to bug 904533.

In fact the symptoms are very similar to what bjacob fixed in bug 900020, except AFAIK that should have been limited to Android 4.3+ and this is on earlier versions. At any rate this looks like a GL problem rather than an APZC problem.
(Reporter)

Comment 6

4 years ago
Reproducible on Firefox Mobile 25 beta 6 on the Samsung Galaxy R (Android 2.3.4)
(Reporter)

Comment 7

4 years ago
Regression window:
2013-07-22 - e3c19a339b36 - good build
2013-07-23 - 5ceea82a79c7 - bad build
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e3c19a339b36&tochange=5ceea82a79c7

Fix window:
2013-08-21 - d136c8999d96 - bad build
2013-08-21 - b2486721572e - good build
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d136c8999d96&tochange=b2486721572e
The fix coincides with the fig to m-c merge so I'm not sure exactly which bug might have fixed this.
Keywords: regressionwindow-wanted
Assignee: nobody → botond
tracking-fennec: ? → 25+
tracking-firefox25: --- → ?

Comment 8

4 years ago
This regression will have to stand for a single release.
status-firefox25: affected → wontfix
tracking-firefox25: ? → -
Just going to mark the whole bug wontfix we have built the 25 release builds.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.