Missing closing tag of alternate content inside OBJECT element causes markup following OBJECT to be ignored

VERIFIED DUPLICATE of bug 88992

Status

()

Core
Layout
--
major
VERIFIED DUPLICATE of bug 88992
17 years ago
13 years ago

People

(Reporter: Greg K., Assigned: karnaze (gone))

Tracking

Trunk
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2) Gecko/20010719
BuildID:    2001071903

When an OBJECT element contains alternate content and that alternate content is
marked up only by an opening tag (the closing tag being omitted as optional),
all markup following the OBJECT element is not displayed.

Reproducible: Always
Steps to Reproduce:
1. Access the test URL or attached testcase 1.

Actual Results:  In both the test URL and the attached testcase, though there is
markup following the OBJECT element, it is not displayed unless the optional
closing tag is added to the alternate content inside the OBJECT.

Expected Results:  Any and all markup following the OBJECT element should have
been displayed.

Attached testcase 2 includes the optional closing tag on the alternate content
inside the OBJECT element, and demonstrates that the content following the
OBJECT element is now displayed.
(Reporter)

Comment 1

17 years ago
*** Bug 91994 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

17 years ago
Created attachment 43282 [details]
Testcase 1: content following the OBJECT element is not displayed
(Reporter)

Comment 3

17 years ago
Created attachment 43284 [details]
Testcase 2: markup following the OBJECT element is displayed.

Comment 4

17 years ago
dupe of bug 88992

*** This bug has been marked as a duplicate of 88992 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.