remove colon tags that show up as default within starter makes

RESOLVED FIXED

Status

Webmaker
Thimble
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Jacob, Assigned: thecount)

Tracking

Details

(Whiteboard: postfest)

(Reporter)

Description

4 years ago
When you publish a Thimble make that's remixed from http://webmaker.org/starter-makes, it autofills these extraneous tags:

webmaker:recommended
webmaker:featured
webmaker:template

They shouldn't be there and are confusing to users. Let's remove them.

Updated

4 years ago
Assignee: nobody → pomax
Whiteboard: mozfest
I thought we had already tackled the issue of webmaker: tags making it into user's remixes? If I remix that as a not-webmaker-admin (using a persona login that gives me normal user access) I can publish with a slew of tags, only only the non-webmaker:*** ones are left in my make. The webmaker:*** ones get stripped out.

Can you confirm this only happens for users with admin rights, or do you also see this happening for regular users?
Flags: needinfo?(jacob)
(Reporter)

Comment 2

4 years ago
:pomax I just confirmed the issue still exists with non admin.

STR:

1) Remixed the Kumi papertoy make from the homepage that was made by non admin user @vikingkarwur - https://vikingkarwur.makes.org/thimble/how-to-make-a-kumi-papertoy/remix

2) Hit publish button for remix while signed in as a non-admin user

3) Ran into the following admin based colon tags - webmaker:p-02, webmaker:featured, webmaker:recommended
Flags: needinfo?(jacob)
handing over to thecount for the moment, as he worked on the webmaker:tag filtering before, and will be able to determine where this bug lives and where the fix is most appropriate. Cursory investigations show this is probably in the makeapi rather than in thimble (and this might affect not just thimble)
Assignee: pomax → scott
Status: NEW → ASSIGNED
(Assignee)

Comment 4

4 years ago
@jacob

Can you confirm this is still an issue?

I just remixed a starter make and don't have the admin tags: https://thimble.webmaker.org/en-us/project/20595/edit

I also did it on the papertoy one, and no tags: https://thimble.webmaker.org/project/10935/remix
Assignee: scott → pomax
Status: ASSIGNED → NEW
Flags: needinfo?(jacob)
(Assignee)

Updated

4 years ago
Assignee: pomax → scott
(Reporter)

Comment 5

4 years ago
Hey :thecount I'm not seeing the admin tags in the final published make, but I do see them in the tag window when you hit the publish button from the starter make remix where you would begin to enter your own tags.

I don't think they carry over on the published make itself, but they do show up in the tagging window and are a little confusing when someone is suppose to add their own individual unique tags and see #webmaker:p-02 etc.

You are seeing the admin tags show up in the publish window, right?
Flags: needinfo?(jacob)
Status: NEW → ASSIGNED

Updated

4 years ago
Whiteboard: mozfest → pozfest

Updated

4 years ago
Whiteboard: pozfest → postfest
(Assignee)

Comment 6

4 years ago
Hey Jacob sorry for the huge delay here.

I do not see them in the publish window even from a remix for the first time.

Maybe this is because I don't have the ability to set these tags, so I also do not see them, which is why the makeapi is not returning it. Either that or this was already fixed.

Do you have an account that is not a mentor account that you can test with?
Flags: needinfo?(jacob)
(Reporter)

Comment 7

4 years ago
Works now. I had tested it a while back with a non-admin account and it was still giving me the issue, but appears resolved.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jacob)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.