Rename nsIContent's SetNativeAnonymous method to SetIsNativeAnonymousRoot to be clear that it should only be called for the root native anonymous element

RESOLVED FIXED in mozilla27

Status

()

defect
RESOLVED FIXED
6 years ago
4 months ago

People

(Reporter: jwatt, Assigned: jwatt)

Tracking

Trunk
mozilla27
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I think we should rename nsIContent::SetNativeAnonymous to nsIContent::SetIsNativeAnonymousRoot to be clearer that this method is for the root native anonymous node only.
Posted patch patchSplinter Review
Attachment #809323 - Flags: review?(bzbarsky)
Comment on attachment 809323 [details] [diff] [review]
patch

r=me
Attachment #809323 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/01bc83765685
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.