mach test should detect test flavor, run appropriate test suite automatically

RESOLVED FIXED in mozilla33

Status

Testing
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: gps, Assigned: gps)

Tracking

Trunk
mozilla33
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

5 years ago
mach test currently supports running test suites only. My vision for this command is for it to facilitate running any test just by specifying its name or path. The command will figure out the "flavor" of the test and run the appropriate suite automatically (probably via native mach command dispatch (bug 913231)).

Now that bug 901990 has landed, we should be able to write out metadata during moz.build traversal describing the flavor of each test. Then, mach test could simply read in a machine-readable file and deduce the flavor of the requested test.

Updated

4 years ago
Duplicate of this bug: 1013560
(Assignee)

Comment 2

4 years ago
I've actively working on this.
Assignee: nobody → gps
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
Created attachment 8442236 [details] [diff] [review]
mach xpcshell-test can now receive test objects

A subsequent patch will have another mach command dispatch into
`xpcshell-test`. To avoid redundant resolution of test paths, we now
support passing resolved test objects into the mach command.
Attachment #8442236 - Flags: review?(dburns)
(Assignee)

Comment 4

4 years ago
Created attachment 8442238 [details] [diff] [review]
mach mochitest can now receive test objects

Similar to the previous patch, we now teach `mach mochitest` how to
execute test objects directly.
Attachment #8442238 - Flags: review?(dburns)
(Assignee)

Comment 5

4 years ago
Created attachment 8442241 [details] [diff] [review]
Teach mach test how to run individual test files

With this change, mach test can now resolve filename arguments to tests
and can dispatch to the appropriate mach commands.

If the arguments contain tests belonging to multiple test
suites/flavors, each relevant test in invoked.
Attachment #8442241 - Flags: review?(dburns)
Attachment #8442236 - Flags: review?(dburns) → review+
Attachment #8442238 - Flags: review?(dburns) → review+
Attachment #8442241 - Flags: review?(dburns) → review+
https://hg.mozilla.org/mozilla-central/rev/78bf44ce0d1b
https://hg.mozilla.org/mozilla-central/rev/f907c87761f5
https://hg.mozilla.org/mozilla-central/rev/06e0a5012ca6
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.