[B2G][MMS]MMS sends to invalid address without displaying error message

RESOLVED DUPLICATE of bug 920546

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 920546
5 years ago
5 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1, URL)

(Reporter)

Description

5 years ago
Sending an MMS to an invalid recipient does not display an error message on device indicating recipient is invalid

Repro Steps:
1) Updated Buri to Build ID: 20130924004002
2) Tap MMS app
3) Tap pencil icon in upper right
4) Type firefoxabc in To: field 
5) Type text in Message field
6) Tap paper clip icon
7) Tap Gallery
8) Select image
9) Deselect crop box
10) Tap Send

Actual:
MMS shows clockwise arrows and makes sound indicating sent message

Expected:
On screen message display that error occurred and MMS could not be sent

Environmental Variables
Build ID: 20130924004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/b34384409be6
Gaia: a13c76f8d3c617ee57c302c103da04ed1a6298d1
Platform Version: 26.0a2

Notes:
Repro frequency: 5/5 - 100%
Test Suite Name: MMS

Link to failed test case: https://moztrap.mozilla.org/manage/case/7775/
See attached: video clip
Optional extra notes:

Tested on the following below Environmental Variables for 1.1 (b2g18) and message did not send. Instead clockwise circling arrows displayed repetitively after user completes Step 10 from STR above. But no error message displayed.

Build ID: 20130924041200
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c6fcfe6a2ad0
Gaia: ff474390146bb8a5b0cce783f8036995fba9fb85
Platform Version: 18.1
RIL Version: 01.01.00.019.222

Updated

5 years ago
blocking-b2g: --- → koi?
Component: Gaia → Gaia::SMS
Keywords: regression, regressionwindow-wanted
This is not a regression but I filed bug 920546 to handle the most broken behaviour for 1.2.
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Last Resolved: 5 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 920546
You need to log in before you can comment on or make changes to this bug.