[B2G][Dialer][Homescreen]Homescreen displays inappropriately after pressing Home button during an ongoing phone call attempt

RESOLVED DUPLICATE of bug 918534

Status

RESOLVED DUPLICATE of bug 918534
5 years ago
5 years ago

People

(Reporter: mclemmons, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 affected)

Details

(Whiteboard: burirun1)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 809527 [details]
Screenshot Homescreen Display Problem

Description: When user makes a phone call within Dialer app and presses the home button with the call ongoing, the header section of the homescreen displays with cut off text and color scheme that appears out of sync

Repro Steps:
1) Updated Buri to Build ID: 20130924004002
2) Tap Dialer App
3) Enter recipient phone number
4) Tap dial button 
5) After call connects, tap home button


Actual:
Homescreen appears with time in upper left and date beneath the time within a green background header, with the date section cut off in the middle where user sees only the top half of each letter or number (i.e. September 24). There is a small gap within the green border toward the top of the display. Below the time/date are homescreen apps

Expected:
Homescreen appears with date and time appearing aligned properly 

Environmental Variables
Build ID: 20130924004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/b34384409be6
Gaia: a13c76f8d3c617ee57c302c103da04ed1a6298d1
Platform Version: 26.0a2

Notes:
Repro frequency: (5/5, 100%)
Test Suite Name: Dialer, Homescreen
See attached: screenshot
Optional extra notes:
Tested on the below Environmental Variables (b2g-18) and couldn’t reproduce issue. Instead, the number dialed shows in a green background in header section of homescreen – aligned properly – above the homescreen apps

Environmental Variables
Build ID: 20130924041200
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c6fcfe6a2ad0
Gaia: ff474390146bb8a5b0cce783f8036995fba9fb85
Platform Version: 18.1
RIL Version: 01.01.00.019.222

Updated

5 years ago
Whiteboard: burirun1
The screenshot here is not easy to see here. Can you provide a better screenshot here of the problem?
blocking-b2g: --- → koi?
Keywords: qawanted

Updated

5 years ago
Keywords: regression
(Reporter)

Comment 2

5 years ago
Created attachment 809978 [details]
Updated Screenshot

Updated screenshot provided

Updated

5 years ago
QA Contact: nkot

Comment 3

5 years ago
Regression range:
Build ID: 20130920004004 - Does NOT Reproduce
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/46b216260c1d
Gaia: 88e73da95f1c550f2fb0572480a40c989d37c997
Platform Version: 26.0a2

Build ID: 20130921004001 - Reproduces
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/20fe34362674
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2
Keywords: qawanted

Updated

5 years ago
Duplicate of this bug: 920865

Updated

5 years ago
Blocks: 921979
triage: koi+ regression
blocking-b2g: koi? → koi+
status-b2g-v1.2: --- → affected
If the issue is with the status bar, it's probably a dup of bug 918534.
If the issue is with the "--" on top of the homescreen (but below the status bar) it's a homescreen bug.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918534
You need to log in before you can comment on or make changes to this bug.