[B2G] [Dialer] "Withheld number" is shown for an incoming call when no call is held

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: gyeh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 809632 [details]
2013-09-25-16-02-52.png

Build info
* Gecko: v1.2, 85ead3614a3de104ca8b52c63a5b9b35c68feaa5
* Gaia: v1.2, 9d2150bd26ca5ff639114dfb0058d35ab871dcc0

STR
1. Turn on Bluetooth.
2. Connect to a Bluetooth headset.
3. Launch Music App and play some music.
4. Make a incoming call.

Actual result: See attachment.

Expect result: There's no call on held. We shouldn't show message like "Withheld number", and the number of incoming call should be shown on screen.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → koi?
Sometimes I see this issue without connecting to any bluetooth device. Is this issue able to be reproduced every time?
Flags: needinfo?(gyeh)
(Reporter)

Comment 2

5 years ago
I just found that it's not always reproducible. Sometimes I can reproduce this issue several times. Sometimes it works well.
Flags: needinfo?(gyeh)
"Withheld number" means the incoming phone number is concealed. I believe it's nothing related to call holding.
(Reporter)

Comment 4

5 years ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #3)
> "Withheld number" means the incoming phone number is concealed. I believe
> it's nothing related to call holding.

Oh, I see. I misunderstood the meaning of "withheld number" :|

It's interesting. I try to make the calls from the same phone. Sometimes it shows "Withheld number", and sometimes it shows the phone number... is it possible?
(Reporter)

Comment 5

5 years ago
Just figured it out that it's because of the phone's configuration. Let's mark it as invalid.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.