Closed Bug 920374 Opened 6 years ago Closed 6 years ago

Switch location region to dropdown menu

Categories

(Participation Infrastructure :: Phonebook, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 976330

People

(Reporter: williamr, Unassigned)

References

(Depends on 1 open bug)

Details

The location region on profiles is currently a text input. In order to make the data consistent (and avoid entries like OR versus Oregon), I suggest we provide lists of regions for countries with known regions. For countries without regions, the field would simply have a "---" value.

Let's start with special cases for Canada and the United States, and use the regions listed below, sorted alphabetically.


[1] http://en.wikipedia.org/wiki/List_of_Canadian_provinces_and_territories_by_population
[2] http://en.wikipedia.org/wiki/List_of_states_and_territories_of_the_United_States
Depends on: 838744
We're going to tackle this in bug 976330, with an input method we've been prototyping there.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976330
Bumping to qa verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.