[Keyboard] Build time default keyboard should use |utils.gaiaOriginURL| to generate app origin

RESOLVED DUPLICATE of bug 913782

Status

RESOLVED DUPLICATE of bug 913782
5 years ago
5 years ago

People

(Reporter: GaryChen, Assigned: GaryChen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Build in apps have different domain, protocol and port in devices and Browser, for example:
 In keyboard apps:
 Devices: app://keyboard.gaiamobile.org
 Browser: http://keyboard.gaiamobile.org:8000

bug 913782 use hard code (app://keyboard.gaiamobile.org) for keyboard layouts in build/settings.js., so it make keyboard framework failed in FF nightly.

So build time default keyboard should use |utils.gaiaOriginURL| to generate app origin
blocking-b2g: --- → koi?
Assignee: nobody → gchen
Created attachment 809692 [details]
pr.html
Attachment #809692 - Flags: review?(yurenju.mozilla)
Comment on attachment 809692 [details]
pr.html

looks good, r=yurenju. please land this commit if you get green state on travis-ci.
Attachment #809692 - Flags: review?(yurenju.mozilla) → review+
Functional issue. Nominate it to koi  blocker.
blocking-b2g: koi? → koi+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Note - in the future, if there's smoketest bustage, you need to backout, instead of doing a forward fix. This might be what caused bug 920588.
Talked to Gary.  he'll backout the changes in this bug and also bug 913782.  it should fix the regression for bug 920588.
Backed out with bug 913782.
I'll set this as a dupe of that, and let's work together to get bug 913782 fixed properly. :)
Resolution: FIXED → DUPLICATE
Duplicate of bug: 913782
Reset flag for duped bug.
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.